Closed Bug 946260 Opened 6 years ago Closed 6 years ago

[Contacts] Broken link image shown for contacts when scrolling instead of their photo

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C1/1.4 S1(20dec)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: gtorodelvalle, Assigned: gtorodelvalle)

Details

Attachments

(2 files)

TO REPRODUCE:

Use Gecko-c5fbc5c and master Gaia as for now :)
1. Open de Contacts app.
2. Import some contacts, probably synchronizing with some Facebook account.
3. Scroll the list of contacts (you can do it up and down continuously without releasing it).

EXPECTED:
4. The photos of the contacts out of the viewport are not shown (a blank space is shown instead) to increase the performance of the scrolling. The photos are reloaded once the scrolling finishes.

OBSERVED:
4. The photos of the contacts out of the viewport are not shown (anyhow, a "broken link ghost image is shown instead" (see attachment)) to increase the performance of the scrolling. The photos are reloaded once the scrolling finishes.
Hi Vicky, could you confirm that a blank space should be shown instead of the "broken link image" shown in the attachment, please? Thanks!
Flags: needinfo?(vpg)
Changing the need-info to Mr. Vittone... ;-)
Flags: needinfo?(vpg) → needinfo?(vittone)
blocking-b2g: --- → 1.3?
Do we have patch for this?
Hi guys,

I guess that a blank space would be correct, but if an image would take that space once loaded it should be reserved to that purpose. I mean, do not allow the text to flow if an image is coming, in order to avoid the movement. 

Am I clear?
Flags: needinfo?(vittone)
Assignee: nobody → gtorodelvalle
Yeap! Thanks Jose.
triage: 1.3+ for "broken link ghost image is shown instead"
blocking-b2g: 1.3? → 1.3+
Attached file 14840.html
Attachment #8349973 - Flags: review?(jmcf)
Comment on attachment 8349973 [details]
14840.html

thanks for the patch. Check Travis if none of the errors are due to this patch, merge, please
Attachment #8349973 - Flags: review?(jmcf) → review+
Merged in master: https://github.com/mozilla-b2g/gaia/commit/ae731e303597aac1cb00657e5e60e4e9f58f4013 Thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
Uplifted ae731e303597aac1cb00657e5e60e4e9f58f4013 to:
v1.3: 5d39cda85d65a77ba5dfcd8576fb2dcf75feea27
You need to log in before you can comment on or make changes to this bug.