LDAP directory with ldif extention appeared after migration

RESOLVED WONTFIX

Status

MailNews Core
LDAP Integration
P3
normal
RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: yulian chang, Assigned: Srilatha Moturi)

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Tested with 0.9, 0.9.1 and 20010809 trunk build.

LDAP directories with ldif extention appeared in Address Book rifgt after
migration until relaunching browser.

Steps to repro,
1. Add a couple of directories in 4.x
2. Do a clean installation of N6.1
3. Migrate the profile
4. Launch Address Book from N6.1

Actual result: "Directory name".ldif appears in AB
 Expected result: 1. "Directory name".ldif should not appear in AB
2.Directory without ldif extention will be added into AB in the future.
(Reporter)

Comment 1

16 years ago
infospace.ldif, Verisign.ldif and netcenter.ldif also showed up in the ABook
right after migration.Even though Inforspace, Verisign and Netcenter LDAP
directories have been removed from Preference.
 

Comment 2

16 years ago
More experimentation needed for triage; in part need to check that directory
servers added in 4.x don't get deleted by the upgrade.  Note that the .ldif
anomaly only shows up on the first startup after migration, and disappears
thereafter.

Comment 3

16 years ago
More experimentation needed for triage; in part need to check that directory
servers added in 4.x don't get deleted by the upgrade.  Note that the .ldif
anomaly only shows up on the first startup after migration, and disappears
thereafter.
Target Milestone: --- → mozilla0.9.5

Updated

16 years ago
Target Milestone: mozilla0.9.5 → mozilla1.0
(Reporter)

Comment 4

16 years ago
infospace.ldif, netcenter.ldif, verisign.ldif and those user created directory
servers with ldif extention appear in the Address Book pane/AddressB window
after migration form 4.x Communicator until relaunching Browser.

This bug will be release noted.

Comment 5

16 years ago
*** Bug 93438 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: nsbeta1

Comment 6

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3

Updated

16 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0.1 → mozilla1.2
(Assignee)

Comment 7

16 years ago
*** Bug 124259 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

16 years ago
With Turbo mode, restart cannot fix it. <ldapname>.ldif always appears in
Address Book until turnning off turbo mode and restart.
(Reporter)

Comment 9

15 years ago
20020506 branch on Win2k

The problem has been fixed for the LDAP Directory servers but not default
Directories which includes infospace.ldif, verisign.ldif and netcenter.ldif.
Please refer to bug 127110 for the default directories problem.

Updated

15 years ago
QA Contact: yulian → gchan
Product: MailNews → Core
as with bug 45777...
->WONTFIX since 4.x migation has been dropped on trunk. 

If one has an overwhelming need to see this fixed on branch, please attach a patch and reopen the bug.  Also, evaluate whether the issue is a bug or an enhancement request and adjust severity accordingly.
filter bugmail for "4.xmidrop" to delete these messages.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core

Updated

3 years ago
Depends on: 948310

Updated

3 years ago
No longer depends on: 948310
You need to log in before you can comment on or make changes to this bug.