Closed Bug 946484 Opened 6 years ago Closed 6 years ago

Ignore "redundant/"-prefixed memory reports.

Categories

(Toolkit :: about:memory, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla28
Tracking Status
firefox26 --- wontfix
firefox27 --- verified
firefox28 --- verified

People

(Reporter: njn, Assigned: njn)

Details

Attachments

(2 files)

Bug 911641 introduced "redundant/"-prefix memory reports, which about:memory
ignored.  Bug 913260 removed them again in favour of a better solution, and
about:memory stopped looking for them.

They were present in the code for less than two weeks, but unfortunately those
two weeks straddled the end of the FF26 dev cycle.  And FF26 was the basis for
B2G 1.2.  So report files are still being produced that contain "redundant/"
reports, and about:memory currently barfs in their presence.

So about:memory needs to just ignore them again.
If we can land this soon, it'll get into FF28.  That'll leave FF27 as the only
version that can't handle files containing "redundant/" reports.  So we should
backport it to FF27 too, just so nobody ever has to deal with this problem
again.
Attachment #8342677 - Flags: review?(khuey)
Comment on attachment 8342677 [details] [diff] [review]
Ignore "redundant/"-prefixed memory reports.

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 911641 in combination with bug 913260.

User impact if declined: Memory report dumps done from FF26 and B2G 1.2 won't be readable in FF27.

Testing completed (on m-c, etc.): landed on mozilla-inbound, with a test.

Risk to taking this patch (and alternatives if risky): negligible.  Patch is trivial.

String or IDL/UUID changes made by this patch:  None.
Attachment #8342677 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b6ca28b144b9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Keywords: verifyme
Comment on attachment 8342677 [details] [diff] [review]
Ignore "redundant/"-prefixed memory reports.

Approving the trivial patch to avoid memory reporting issues.:njn, can you also please help with verification that this is working as expected once this lands.Thanks !
Attachment #8342677 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Here's a test file that will fail to load without the fix.  Note that if you download it via Bugzilla, it'll be gzipped again and you'll need to gunzip it.  I recommend instead downloading it via |wget| or |curl|.
I tried to reproduce this issue on Firefox 26.0b10, 27.0b1 and 28.0a2. Whenever I tried to load the test file from comment 6, I got this error: "SyntaxError: JSON.parse: unexpected character". The file was obviously not loaded.

Is this what you were referring to with "will fail to load"?
Flags: needinfo?(n.nethercote)
(In reply to Ioana Budnar, QA [:ioana] from comment #8)
> I tried to reproduce this issue on Firefox 26.0b10, 27.0b1 and 28.0a2.

Tested on Windows 7 64-bit and Ubuntu 13.04 32-bit.
> "SyntaxError: JSON.parse: unexpected character".

This is almost certainly the double-zipping Bugzilla issue I mentioned in comment 6.  Now that you have a copy of the file, I suggest that you gunzip it, rename it so it has a .json.gz extension, and try loading again.
Flags: needinfo?(n.nethercote)
(In reply to Nicholas Nethercote [:njn] from comment #10)
> > "SyntaxError: JSON.parse: unexpected character".
> 
> This is almost certainly the double-zipping Bugzilla issue I mentioned in
> comment 6.  Now that you have a copy of the file, I suggest that you gunzip
> it, rename it so it has a .json.gz extension, and try loading again.

I did gunzip it, but didn't rename it. Didn't know about that before, thanks. It works now. The problem is that now it also gets loaded in Firefox 26.0b10, where it shouldn't.
Any ideas what's happening here (comment 11)?
Flags: needinfo?(n.nethercote)
> The problem is that now it also gets loaded in Firefox 26.0b10, where it shouldn't.

It's expected to work in FF26.  I don't think this is a problem.
Flags: needinfo?(n.nethercote)
Since Firefox 26 is marked as wontfix, I supposed the bug would reproduce there. Apparently not. It did reproduce on Firefox 27.0a2 though.

Verified as fixed on Firefox 27.0b1 and the 12/11 Firefox 28.0a2, on Windows 7 64-bit and Ubuntu 13.04 32-bit.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: ioana.budnar
You need to log in before you can comment on or make changes to this bug.