Closed Bug 946639 Opened 7 years ago Closed 7 years ago

enable AVX2 on Linux if supported (libvpx)

Categories

(Core :: Audio/Video, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: j, Assigned: rillian)

References

Details

Attachments

(2 files)

Current toolchain on build servers does not support AVX2. Once its supported Linux builds should use AVX2.
Depends on: 918550
Summary: enable AVX2 on Linux is supported (libvpx) → enable AVX2 on Linux if supported (libvpx)
Looks like a valid bug to me, so confirming :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
According to glandium on irc, the issue is the binutils version on our build machines; gcc supports the instructions, but the assembler does not.
Depends on: 938510
Attached patch Enable AVX2Splinter Review
Hmm. This patch actually passes try. Maybe this is a different issue from libyuv because libvpx uses intrinsics for this instead of inline assembly?
Assignee: nobody → giles
Attachment #8360512 - Flags: review?(cpearce)
Comment on attachment 8360512 [details] [diff] [review]
Enable AVX2

Review of attachment 8360512 [details] [diff] [review]:
-----------------------------------------------------------------

I wonder if we can enable this on Windows too?
Attachment #8360512 - Flags: review?(cpearce) → review+
(In reply to Chris Pearce (:cpearce) from comment #5)

> I wonder if we can enable this on Windows too?

As soon as we move to VS2012. :)

https://hg.mozilla.org/integration/mozilla-inbound/rev/684a92697548
While enabling it for builds, would be also good to remove the special case from update.py to disable it.
https://hg.mozilla.org/mozilla-central/rev/684a92697548
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Blocks: 960840
Depends on: 1062026
You need to log in before you can comment on or make changes to this bug.