Update the gaia-ui-tests for running on emulators

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: davehunt, Assigned: davehunt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

There are some changes needed to get the gaia-ui-tests running on emulators. This bug will track that work.
Comment on attachment 8342989 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14395

This initial patch should make sure the unit tests pass on emulator and the camera tests are marked as expected to fail due to bug 946375. I'm going to raise another bug to get the tests running against the emulator on the cedar branch, as running them locally is painfully slow.
Attachment #8342989 - Flags: review?(jgriffin)
Depends on: 946649
Comment on attachment 8342989 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14395

nice, thanks for doing this!
Attachment #8342989 - Flags: review?(jgriffin) → review+
Comment on attachment 8344749 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14511

My last patch introduced a syntax issue, which caused the tests to be skipped on all devices.
Attachment #8344749 - Flags: review?(jgriffin)
Comment on attachment 8344749 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14511

ah yes, sorry for not catching that!
Attachment #8344749 - Flags: review?(jgriffin) → review+

Comment 9

6 years ago
Looks like this was merged in above comment #8.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No, this is blocked and there's much more work to do here.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Bug 946649 is resolved and we have many test failures on cedar. They look to be mostly related to timeouts, which is not surprising considering the emulator performance. I pick up my new work laptop next week so once I have that I'll set up a VM and look into this again.
Flags: needinfo?(dave.hunt)
Dave any updates on this? Can we help with anything?
Every test is currently timing out on the emulator.  You could try running them locally and debug this if you have time.
I tried this myself locally and found that the tests generally run fine; I think the problem is that the VM they're running on in TBPL is not powerful enough to run them in any reasonable amount of time.  I'm going to file a bug to try running them on real hardware and see if that allows them to pass.
Depends on: 1019824
Flags: needinfo?(dave.hunt)
QA Whiteboard: [fxosqa-auto-backlog-]
Recently, it's confirmed by QA that gaia-ui-tests run well on local emulator. 

Per comment 13, this seems be talking about gaia-ui-tests for running on emulators on Try. Make the bug description more descriptive.
Summary: Update the gaia-ui-tests for running on emulators → Update the gaia-ui-tests for running on emulators on TPBL
So it seems a duplicate of bug 916368? Or, what are the scopes these two bugs focus on?
Bug 916368 is for running the Gaia UI tests on buildbot and reporting to Treeherder. This bug is about getting the tests into shape for running on the emulator (and adjusting the manifests if any need to be skipped). For example, we can't run camera or wifi tests on the emulator.
(In reply to Dave Hunt (:davehunt) from comment #17)
> Bug 916368 is for running the Gaia UI tests on buildbot and reporting to
> Treeherder. This bug is about getting the tests into shape for running on
> the emulator (and adjusting the manifests if any need to be skipped). For
> example, we can't run camera or wifi tests on the emulator.

Thanks for the clarification.
Summary: Update the gaia-ui-tests for running on emulators on TPBL → Update the gaia-ui-tests for running on emulators
These tests are being replaced with MarionetteJS tests, so this won't be needed.
Status: REOPENED → RESOLVED
Closed: 6 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.