Open Bug 946757 Opened 6 years ago Updated 6 years ago

Failed to import visit count history from Chrome

Categories

(Firefox :: Migration, defect)

defect
Not set

Tracking

()

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131030131734

Steps to reproduce:

Firefox -> Bookmarks -> Show All Bookmarks -> Import and Backup -> Import Data from Another Browser -> Chrome -> Next.

(In this case I had Chromium installed instead of Chrome, so first ran "ln -s ~/.config/chromium ~/.config/google-chrome" to allow the import to proceed)

Chromium version: "Version 27.0.1453.93 Built from source for Fedora release 19 (Schrödinger’s Cat) (200836)"


Actual results:

Enable the Visit Count column in the table.   The value for each imported bookmark and history item is always 1.


Expected results:

Ideally, the correct visit count would be preserved.  Rummaging in ~/.config/chromium/Default/History with sqlite3 I see that there is a visit_count column in the urls table, so it should be do-able.
Component: Untriaged → Migration
This is a limit of the migration system, since Chrome doesn't store single visits, to get a proper visit count we should artificially add fake visits between the first and last visit date. We choose by policy to never add fake information to the users profiles, since it may create more trouble than gain to the behavior of awesomebar, or privacy issues. So, this is not a bug but a design choice.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
(In reply to Marco Bonardo [:mak] from comment #1)
> This is a limit of the migration system, since Chrome doesn't store single
> visits, to get a proper visit count we should artificially add fake visits
> between the first and last visit date. We choose by policy to never add fake
> information to the users profiles, since it may create more trouble than
> gain to the behavior of awesomebar, or privacy issues. So, this is not a bug
> but a design choice.

Perhaps I'm missing some subtelty, but my ~/.config/chromium/Default/History from Chromium 27 contains the following table that appears to store individual visits:

CREATE TABLE visits(id INTEGER PRIMARY KEY,url INTEGER NOT NULL,visit_time INTEGER NOT NULL,from_visit INTEGER,transition INTEGER DEFAULT 0 NOT NULL,segment_id INTEGER,is_indexed BOOLEAN, visit_duration INTEGER DEFAULT 0 NOT NULL);
thanks for checking, could be I'm misremembering and it was done that way just for performance reasons (importing thousands of entries may take a really long time), I will verify.
Flags: needinfo?(mak77)
btw, no reason to keep this wontfix, since it should be investigated.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(mak77)
Resolution: WONTFIX → ---
Status: REOPENED → NEW
OS: Linux → All
Hardware: x86 → All
Version: 25 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.