Make TBPL display 'mochitest-debug-N' chunks with the chunk number

RESOLVED FIXED

Status

Tree Management Graveyard
TBPL
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jgriffin, Assigned: jgriffin)

Tracking

Dependency tree / graph

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
We've introduced a new suite name, mochitest-debug, for debug mochitests run on B2G.  We've done this to allow us to use different chunk numbers in opt vs debug builds.

Currently, these are running only on cedar and pine, where each chunk shows up as "M".  We should make TBPL recognize mochitest-debug, so the chunks will show up as M(1, 2, ...).
(Assignee)

Comment 1

4 years ago
Created attachment 8343217 [details] [diff] [review]
Recognize mochitest-debug chunks,
Attachment #8343217 - Flags: review?(emorley)
Can't we just put a (-debug) on the mochitest condition (or something to that effect)?
Confirmed that this does the trick:
(?:mochitest(?:-debug)?|reftest|crashtest|robocop|androidx86-set|browser-chrome)\-([0-9]+)
(Assignee)

Comment 4

4 years ago
Created attachment 8343259 [details] [diff] [review]
Recognize mochitest-debug chunks,
Attachment #8343259 - Flags: review?(emorley)
(Assignee)

Updated

4 years ago
Attachment #8343217 - Attachment is obsolete: true
Attachment #8343217 - Flags: review?(emorley)
(Assignee)

Updated

4 years ago
Attachment #8343259 - Flags: review?(emorley) → review?(ryanvm)
Comment on attachment 8343259 [details] [diff] [review]
Recognize mochitest-debug chunks,

LGTM, but Ed really should review this. He'll be back soon.
Attachment #8343259 - Flags: review?(ryanvm)
Attachment #8343259 - Flags: review?(emorley)
Attachment #8343259 - Flags: feedback+

Comment 6

4 years ago
Comment on attachment 8343259 [details] [diff] [review]
Recognize mochitest-debug chunks,

(Have been PTO since Fri eve 29th Nov, hence delay :-))

lgtm, and tests fine locally; thank you :-)
Attachment #8343259 - Flags: review?(emorley) → review+
(Assignee)

Comment 7

4 years ago
https://hg.mozilla.org/webtools/tbpl/rev/56ed408d90e9
(Assignee)

Updated

4 years ago
Blocks: 949255
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
No longer blocks: 949255
Depends on: 949255
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.