Closed Bug 946874 Opened 7 years ago Closed 7 years ago

[DSDS][Dialer] Display receiving SIM on call screen

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S3 (14mar)

People

(Reporter: wmathanaraj, Assigned: etienne)

References

Details

(Whiteboard: [ucid:, 1.4, ft:comms])

Attachments

(12 files)

As a user, when I receive a phone call, I want to be informed on which SIM the call is received.

Acceptance Criteria

AC1: I want an easy to understand, on the receiving call screen, to show via which SIM the call is being received
AC2: If the device is locked and a call is received I want to see via which SIM the call is received
Summary: [DSDS] Display receiving SIM on call screen → [DSDS][Dialer] Display receiving SIM on call screen
Duplicate of this bug: 947130
Attached image DSDS.Call_Incoming.png
Visuals and visual specs related to DSDS.
Attached image DSDS.Call_Outgoing.png
Attached image DSDS.Dailer.png
Attached image SPEC_DSDS.Dialer.png
Attachment #8374214 - Attachment description: DSDS.Dialer.SPEC.incomming_call.png → SPEC_DSDS.Dialer.incomming_call.png
Attachment #8374214 - Attachment filename: DSDS.Dialer.SPEC.incomming_call.png → SPEC_DSDS.Dialer.incomming_call.png
Attachment #8374220 - Attachment description: DSDS.Dialer.SPEC.2nd_incomming_call.png → SPEC_DSDS.Dialer.2nd_incomming_call.png
Attachment #8374220 - Attachment filename: DSDS.Dialer.SPEC.2nd_incomming_call.png → SPEC_DSDS.Dialer.2nd_incomming_call.png
Attachment #8374221 - Attachment description: DSDS.Dialer.SPEC.png → SPEC_DSDS.Dialer.png
Attachment #8374221 - Attachment filename: DSDS.Dialer.SPEC.png → SPEC_DSDS.Dialer.png
Attachment #8374222 - Attachment description: DSDS.Dialer.SPEC.sim_picker.png → SPEC_DSDS.Dialer.sim_picker.png
Attachment #8374222 - Attachment filename: DSDS.Dialer.SPEC.sim_picker.png → SPEC_DSDS.Dialer.sim_picker.png
features should not block release, remove blocking flag
blocking-b2g: 1.4+ → ---
Whiteboard: [ucid:, 1.4, ft:comms]
Flags: in-moztrap?(atsai)
QA Contact: atsai
#11674
Flags: in-moztrap?(atsai) → in-moztrap+
Assignee: nobody → anthony
Hi guys, 

According to bug 947180, Message owner found that if we use "SIM 1 - " as the SIM indication for notification, it will look like "SIM 1 - +886931888888" for unknown sender, which looks quite weird. Hence, we decide to change it to "(SIM 1) +886931888888" (use parentheses rather than dash). In this way, we shall fix Dialer's notification as well to make it consistent in notification centre. So, it will look like "(SIM 1) Missed call". 
I'll update this to my spec as a reference and upload it later.

Hi Anthony, 

I don't really know who's in charge of this feature. Hence, I assign it to you. :) 
Feel free to switch it to the right person. Thanks!!
Hi, 

Just attached the revised spec here. Please refer to p.6-7.
Thanks!
ni? Etienne to see if Etienne will be able to work on this one
Flags: needinfo?(etienne)
from a separate conversation, this is targeted to be done by end of Sprint 3
Target Milestone: --- → 1.4 S3 (14mar)
(In reply to Carrie Wang [:carrie] from comment #14)
> Hi Anthony, 
> 
> I don't really know who's in charge of this feature. Hence, I assign it to
> you. :) 
> Feel free to switch it to the right person. Thanks!!
I've opened bug 979453 to track this because it's about notifications, not call screen (topic of this bug)
Talked with Rik, taking this one for this week.
Assignee: anthony → etienne
Flags: needinfo?(etienne)
Attached file Gaia PR
Attachment #8389322 - Flags: review?(anthony)
Comment on attachment 8389322 [details] [review]
Gaia PR

\o/
Attachment #8389322 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/ea9e23abea5933656555d849b922c8da7530c90b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I'm wondering about

+## LOCALIZATION NOTE "via" will be hidden in some cases
+via-sim=<span>via</span> SIM{{ n }}


In which cases is it one or the other?

The reason for asking is that "through something" is a different grammatical context than "something", and might yield a different localization.

Also, technically, should the whitespace be inside or outside of the <span>?
(In reply to Axel Hecht [:Pike][pto til 14th] from comment #23)
> I'm wondering about
> 
> +## LOCALIZATION NOTE "via" will be hidden in some cases
> +via-sim=<span>via</span> SIM{{ n }}
> 
> 
> In which cases is it one or the other?

* |via SIM1| is displayed on the call screen when only 1 call is going on
* the call waiting UI only displays |SIM1|
* the incoming call screen while the phone is locked only displays |SIM1|

> Also, technically, should the whitespace be inside or outside of the <span>?

I guess it should be inside.
A small follow is probably in order :)
(In reply to Etienne Segonzac (:etienne) from comment #24)
> * |via SIM1| is displayed on the call screen when only 1 call is going on
> * the call waiting UI only displays |SIM1|
> * the incoming call screen while the phone is locked only displays |SIM1|

I'm not sure having such a string is enough for some locales. Take for example Czech:
* Locked SIM card -> SIM karta uzamčena
* SIM {{n}} PIN -> PIN karty SIM {{n}}

Having two separate strings and swapping them at run-time ("via SIMx", "SIMx"), instead of hiding the span, should be safer.

Also: there are already strings that use "SIM x" instead of "SIMx" in the same .properties file.
(In reply to Francesco Lodolo [:flod] from comment #25)
> Also: there are already strings that use "SIM x" instead of "SIMx" in the
> same .properties file.

Correction: in the whole Gaia there's currently only one string using SIMx (no space), and it's in SMS App
https://github.com/etiennesegonzac/gaia/blob/master/apps/sms/locales/sms.en-US.properties#L210
We use "SIM x" in https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/locales/sim.en-US.properties.

We could probably group all SIM related sentences together.
(In reply to Anthony Ricaud (:rik) from comment #27)
> We use "SIM x" in
> https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/
> locales/sim.en-US.properties.

Exactly. Only one other app (SMS) is currently using "SIMx", and it's worth fixing if you need to change the strings.
Given all those comments, and taking into account that apparently UX and visual do not agree on weather there should be a space between SIM and the number, and that we might have a space on the button but not on the call screen.

What is the safest follow up we can do this close to string freeze? :)
Flags: needinfo?(l10n)
Consistency is the easy answer on simx vs sim x.

I agree that we should split the via and the non-via strings into two. Probably also resolves the problem of where the space goes?
Flags: needinfo?(l10n)
Works fine with this
Gaia      d2651c13d6370d62bf833b31c7e2e5f054510136
Gecko     c8a17e25111585c0eebb829f8208190ea432c71e
BuildID   20140318053055
Version   30.0a1
Status: RESOLVED → VERIFIED
Keywords: verifyme
Blocks: 984882
No longer blocks: 984882
Depends on: 984882
QA Whiteboard: [fxosqa-auto-backlog?]
Depends on: 1093589
QA Whiteboard: [fxosqa-auto-backlog?] → [fxosqa-auto-backlog+]
Clearing backlog as bug 1093589 was created (and fixed).
QA Whiteboard: [fxosqa-auto-backlog+]
You need to log in before you can comment on or make changes to this bug.