Closed Bug 947004 Opened 6 years ago Closed 4 years ago

[B2G][Homescreen] Pulling down and closing the notifications utility bar is sluggish when in edit mode

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g18 affected, b2g-v1.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g18 --- affected
b2g-v1.2 --- affected

People

(Reporter: KTucker, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [c=handeye p= s= u=] dogfood1.2)

Attachments

(2 files)

Description:
If the user long presses on an app on the homescreen to enter edit mode and then pulls down the notificaitons/utility bar, they will notice that the performance is very sluggish. Sometimes, it seems difficult to fully pull down the utility bar at all. 

Repro Steps:
1)  Updated Buri to Build ID: 20131205040201
2)  Long press on an app on the homescreen to enter edit mode.
3)  Try to pull down the "Utlity/Notifications" bar and then try to close it.

Actual:
Pulling down the utility/notifications bar is sluggish when the user is in edit mode.

Expected:
The utility/notifications bar pulls down and closes smoothly.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131204004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/758f3fb32dda
Gaia: 8d762f3376318fd6be390432db750ae4904c9ab6
Platform Version: 26.0
RIL Version: 01.02.00.019.102 

Notes:
Repro frequency: 100%
See attached: video clip, logcat
This issue occurs on the Leo v 1.1.0 COM RIL 

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20131205041342
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/05117f42088f
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281 

Pulling down and closing the utility bar is sluggish when in edit mode.
Keywords: perf
To be honest the edit mode animation has not changed in the last year so the regression shouldn't be in the homescreen. It could be a regression maybe in Gecko
Component: Gaia::Homescreen → Gaia
Whiteboard: dogfood1.2 → [c=handeye p= s= u=] dogfood1.2
Putting it back to Homescreen because that's where the effect is. If there's an associated Gecko problem, please put it in as a "depends on".

iOS kicks you out of edit mode as soon as you pull down the notification center, btw. That would avoid the problem in general.
Component: Gaia → Gaia::Homescreen
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.