[Buri][Settings] System and Purchased Ringtones overlap check boxes

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: marcia, Assigned: pdahiya)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

Attachments

(2 attachments)

Buri, while running:

Gaia   1dd0e5c644b4c677a4e8fa02e50d52136db489d9
SourceStamp 725c36b5de1a
BuildID 20131205040201
Version 28.0a1

STR:
1. Settings | Sound | Ringer
2. Open the menu 
3. Observe the attached screenshot

This works correctly using a 1.2 build:

Gaia   0659f16b9790b1cf9eba4d80743fcc774d2ffe3a
SourceStamp af2c7ebb5967
BuildID 20131205004003
Version 26.0
Created attachment 8343442 [details]
Screenshot of issue in Settings using 1.3 build
(Reporter)

Updated

5 years ago
Keywords: qawanted
This might be another fallout from the screen reader work. A regression window will confirm that.
Keywords: qawanted

Updated

5 years ago
QA Contact: nkhristoforov

Comment 3

5 years ago
The regression window for this bug is 11-13 to 11-14.

Last Working Build:
Device: Buri v1.3 Moz RIL
BuildID: 20131113040200
Gaia: 7243b75041c93bc7deb240131748d0b164f3f0b0
Gecko: 7b014f0f3b03
Version: 28.0a1

First Broken Build:
Device: Buri v1.3 Moz RIL
BuildID: 20131114143149
Gaia: 4ea5adac92d6a9ab035e708e941d50be0d670da2
Gecko: 7b014f0f3b03
Version: 28.0a1
Keywords: regressionwindow-wanted
Yup, it's another fallout from bug 914892.
Blocks: 914892

Updated

5 years ago
Duplicate of this bug: 947472
(Assignee)

Updated

5 years ago
Assignee: nobody → pdahiya
Triage: regression.
blocking-b2g: 1.3? → 1.3+
(Assignee)

Comment 7

5 years ago
Created attachment 8345382 [details] [review]
Pull request with the fix of overlapping check boxes

Hi David, Attached is the fix inside ringtones.css for the overlapping option buttons. Please review. Thanks
Attachment #8345382 - Flags: review?(dflanagan)
Comment on attachment 8345382 [details] [review]
Pull request with the fix of overlapping check boxes

Trivial fix. Looks good to me.
Attachment #8345382 - Flags: review?(dflanagan) → review+
On second thought...  The subject line of this bug implies that purchased ringtones have the same bug. Has anyone actually checked that? The attached patch does not fix purchased ringtones, so we may well need to make the same change in apps/fl/style/pick.css
(Assignee)

Comment 10

5 years ago
(In reply to David Flanagan [:djf] from comment #9)
> On second thought...  The subject line of this bug implies that purchased
> ringtones have the same bug. Has anyone actually checked that? The attached
> patch does not fix purchased ringtones, so we may well need to make the same
> change in apps/fl/style/pick.css

Good catch, i have fixed and tested UI for purchased ringtones. Please review. Thanks
(Assignee)

Updated

5 years ago
Flags: needinfo?(dflanagan)
(Assignee)

Comment 11

5 years ago
Synched up with djf over IRC and the fix looks good. Carrying over the r+ and landing the patch on master
Flags: needinfo?(dflanagan)
(Assignee)

Comment 12

5 years ago
Patch merged with master https://github.com/mozilla-b2g/gaia/commit/dea74850442df6aff8405333a973d49a9f1af2ec
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 949718

Updated

5 years ago
Duplicate of this bug: 956981
Uplifted dea74850442df6aff8405333a973d49a9f1af2ec to:
v1.3: 07315d8a283fae4fb24e9f3cc65532ec933f255b
status-b2g-v1.3: --- → fixed
Still seeing this on Buri 1.3 mozilla RIL.  However, it does not appear on 1.4.  Should I write a new bug?

Buri 1.3
Build ID: 20140102004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/61f553e5db49
Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
Platform Version: 28.0a2
Firmware Version: V1.2-device.cfg
(In reply to ckreinbring from comment #16)
> Still seeing this on Buri 1.3 mozilla RIL.  However, it does not appear on
> 1.4.  Should I write a new bug?
> 
> Buri 1.3
> Build ID: 20140102004001
> Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/61f553e5db49
> Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
> Platform Version: 28.0a2
> Firmware Version: V1.2-device.cfg

Yes - file a new bug.
You need to log in before you can comment on or make changes to this bug.