Closed Bug 947042 Opened 6 years ago Closed 6 years ago

[B2G] [RIL] crash on mozilla::dom::network::MobileConnection::Listener::NotifyRadioStateChanged

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 946437

People

(Reporter: hsinyi, Unassigned)

References

Details

Crash Data

Attachments

(1 file)

This bug was originally reported at bug 933203. 

STR:
1) apply gaia patch on attachment 8343178 [details] [diff] [review] for bug 933203
2) run marionette test locally, i.e. ./mach marionette-webapi

Actual result:
crash with SIGSEGV, Segmentation fault

Expected result:
no crash


With more investigation, bug 933203 comment 42 and bug 933203 comment 44 point the root cause.
Attached patch 947042.wip.patchSplinter Review
Shutdown() in 
1) MobileConnection unlink
2) MobileConnection destructor
Blocks: 933203
See Also: → 946437
Crash Signature: [@ mozilla::dom::network::MobileConnection::Listener::NotifyRadioStateChanged()]
blocking-b2g: --- → 1.3?
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946437
No longer blocks: 933203
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.