We should not autolink when a new line is inside the string

RESOLVED DUPLICATE of bug 105865

Status

()

RESOLVED DUPLICATE of bug 105865
5 years ago
5 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
see bug 947092 comment 0. The reporter did one line finishing with "attachment" and the next line was starting with 3, and this triggered autolinking for "attachment 3 [details] [diff] [review]".

Here is another try:
2. see attachment
3 [review]. next step

Comment 1

5 years ago
It's a feature. Changing this would also make bug
947118 not be autolinked anymore. So question is "link too much with false positives" or "link not enough with missing links".
(Reporter)

Comment 2

5 years ago
For attachments, the issue is that some additional text is adding, and this makes a very difficult to read text when it's wrong.

I don't know when the autolinking is done, but if the new line was added by the user, then I think it should not autolink.

If you're doing autolinking after Bugzilla is adding new lines for some reason, then it's more difficult.

Comment 3

5 years ago
(In reply to Andre Klapper from comment #1)
> It's a feature. Changing this would also make bug
> 947118 not be autolinked anymore.

No, that's a bug, and if a user includes a newline, the string must not be linkified. This has already been fixed in Bugzilla 4.5.1.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 105865
(Reporter)

Comment 4

5 years ago
Great, thanks Frédéric. Now I see BMO's version is severely lagging behind :(
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Great, thanks Frédéric. Now I see BMO's version is severely lagging behind :(

note- that fix hasn't been released in any stable version of bugzilla.
You need to log in before you can comment on or make changes to this bug.