autocomplete search not in sync with what is actually typed in url box (last characters/letters/keystrokes truncated)

VERIFIED FIXED in mozilla0.9.4

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: buggage1999, Assigned: hewitt)

Tracking

({regression})

Trunk
mozilla0.9.4
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.3+) Gecko/20010810
BuildID:    2001081003

The autocomplete search feature seems to be a character or two behind what is
actually typed in the url box - type mozilla and get mozil or mozill, but never
the whole thing.  Strange behavior when typing and deleting.

Reproducible: Always
Steps to Reproduce:

1. Have autocomplete on with show internet search
2. Start typing in the url box
3. Note that the internet search hesitates and is not in sync as you type,
leaving off the last letter or so

Actual Results:  Internet search does not match what is in the url field

Expected Results:  Should be in sync - letter for letter

Comment 1

17 years ago
Confirmed WinMe 2001081003

The Internet Search feature of autocomplete is one character behind what is
typed in.

e.g., I type in "test search" and the Internet Search feature shows "test searc"
now, if I then hit backspace so that the URLbar shows "test searc" , then the
autocomplete shows "test search"     It always lags one character behind what's
typed in.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Could be related to whatever was done to fix bug 94153 ?
adding regression keyword
Keywords: regression

Comment 3

17 years ago
That's bug 94143
sorry....

Comment 4

17 years ago
*** Bug 94835 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
Changing OS to all per bug 94835
OS: Windows ME → All

Comment 6

17 years ago
*** Bug 94865 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
I like the summary from dup bug 94865 more. Have you seen the autocomplete
really miss more than one letter?

Comment 8

17 years ago
Jacek:   No, this summary is much better.  Read my comments from 2001-08-10 13:25
Originally I thought it was always one character, but I have seen it 2
characters behind.

Comment 9

17 years ago
I found it depending on your typing speed and typing correctness. Look at my
attachment.
The URL is complete, but autocomplete is 2 letters behind.

BTW, this works the other way round, too. If you backspace, autocomplete shows
too much letters.

(Mozilla 2001081008, Linux)

Comment 10

17 years ago
Created attachment 45553 [details]
Screenshot

Comment 11

17 years ago
Note:  If you paste text into the URLbar, the autocomplete portion correctly
shows the entire string.

Comment 12

17 years ago
*** Bug 95120 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
I'm seeing this too, for me it's 1 keystroke behind. This inclused backspacing
and deleting.

Comment 14

17 years ago
*** Bug 95734 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
*** Bug 95739 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
Added mostfreq keyword based on 7 votes and 5 duplicates.
Keywords: mostfreq
*** Bug 95827 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
Yes, it's speed related. Type "a" and hold it down. The search bar will only
show the first letter. Release a, and press space bar. It will show all letters.
I thought this bug was only "visual" but i actually clicked on the search bar
and it searched for the incomplete stuff. We need to find where the regression
appeared.
I was in google search, so i changed to netscape search, and now the search bar
shows nothing! I tried to go back to google search and the problem is still
there. Maybe restarting.
Nominating for 0.9.4
Keywords: mozilla0.9.4

Comment 19

17 years ago
I checked the regression on this, it's posted in bug 95120.  Definitely seems to
have been introduced either between -06-09 and -07-06, when the "search bar
doesn't work" bug was introduced, or two days later between -08-21 and -09-10,
when that bug was fixed.

Comment 20

17 years ago
nav triage team:

Reassigning to Joe Hewitt since he owns auto-complete and besides Alec has been
on sabbatical, so he couldn't have broken this. Also cc-ing Hangas.
Assignee: alecf → hewitt

Comment 21

17 years ago
*** Bug 95932 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
*** Bug 96060 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
This bug has so many dupes due to an IMHO not helpful summary. I changed the
summary adding the most common words from the dup summaries.
Summary: autocomplete search not in sync with what is actually typed in url box → autocomplete search not in sync with what is actually typed in url box (last characters/letters/keystrokes truncated)

Comment 24

17 years ago
I dont like that new summary IMHO. It will confuse the readers , because the
most common symtom is "the last char is not being typed" while the real problem
is that the last _operation_ is not being printed on the screen. "operation"
meaning, typing, erasing, etc... What i mean, the lack of printing in the last
operation is what is causing the last letter not being typed, or when using
backspace, a letter being typed when it should have been deleted... I think you
get the point

Comment 25

17 years ago
You cannot safisfy everyone. On 8/11 I proposed changing the summary to that of
dup bug 94865:  "Last letter for Autocomplete web search is missing" and was
told some people see two letters missing. 

As most people see only one letter missing, the summary of bug 94865 is still my
favorite :-(

Comment 26

17 years ago
*sigh* as i said, it's not the lack of LETTERS, it's the lack of *operations*
Typing forward is one operation, using backspace is another type of operation,
and so on. We already established too that it's speed related, but for "normal"
people , it's one operation the UI and back end fail to show.
Now, this is not helping to fix this bug. We need a target milestone soon, and i
know it's kind of late to assign it to 0.9.4, but we will get BURIED in dupes if
we ship 0.9.4 with this!
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: mozilla0.9.4
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 27

17 years ago
Created attachment 46520 [details] [diff] [review]
patch to fix

Comment 28

17 years ago
The patch works for me. FreeBSD 4.3-STABLE

Comment 29

17 years ago
*** Bug 96258 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 30

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 31

17 years ago
VERIFIED Fixed with 20010907 builds
Status: RESOLVED → VERIFIED

Comment 32

16 years ago
This regressed for form autocomplete as bug 212487, which has already been fixed.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.