Closed Bug 947280 Opened 6 years ago Closed 2 years ago

[DSDS][EAP-SIM] Support DSDS for EAP-SIM

Categories

(Firefox OS Graveyard :: Wifi, defect, P1)

x86
macOS
defect

Tracking

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.0M affected)

RESOLVED WONTFIX
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected

People

(Reporter: wmathanaraj, Unassigned)

References

Details

Attachments

(3 files)

As a user I want to be able select which sim I use for eap sim authentication.

Acceptance Criteria

AC1: i want to have an option in the EAPSIM setting to choose which SIM i authenticate with
AC2: I want to choose a SIM indepednant of which evrer is the primary SIM
Depends on: 939000
Summary: [DSDS] [WIFI] Support DSDS for EAP-SIM → [DSDS] [EAP-SIM] Support DSDS for EAP-SIM
Summary: [DSDS] [EAP-SIM] Support DSDS for EAP-SIM → [DSDS][EAP-SIM] Support DSDS for EAP-SIM
This story depends on whether we have reference device for development or not.
So far we do not have workable phones yet.
I wonder if we need this user story now. I prefer to have this feature after wpa_supplicant support it. Since the interface will be more well-defined in wpa_supplicant, we won't create a proprietary mechanism for firefox os.
Flags: needinfo?(wmathanaraj)
Assignee: nobody → nhsieh
Looks like this user story has primary SIM option for user. 
If the primary SIM is not work, the another SIM will auto turn on for EAP-SIM ?
Flags: needinfo?(whuang)
No. The other SIM should not be automatically applied for EAP-SIM.
Flags: needinfo?(whuang)
Please check attached file. Thanks
Hi Neo,

I have a question in single SIM case. Shell we grey out(disable) or remove the SIM option?
For DSDS we need a way to manage this. the user must be able to select if he wants to use SIM1 or SIM2 for EAP-SIM. Perhaps we can link this selection with the SIM enabled for Data and so reduce the work that needs to be done.

So if a user selects SIM1 for data then that SIM will also be used for EAP-SIM. Else if a user selects SIM 2 for data then that SIM will be used for EAP-SIM.
Flags: needinfo?(wmathanaraj)
(In reply to Wilfred Mathanaraj [:WDM] from comment #7)
> So if a user selects SIM1 for data then that SIM will also be used for
> EAP-SIM. Else if a user selects SIM 2 for data then that SIM will be used
> for EAP-SIM.
The current attached UX document "[DSDS] Settings_WPA_EAP_SIM_140106.pdf" covers AC1 and AC2.
Thus, I propose we stick to the defined flow unless we think it's not user friendly or technically not feasible. Namely, there will be options for configuring which SIM to be used under a specific EAP-SIM hotspot.
Also in reply to Ian's question in comments 6: page5 of the document says it should gray out.
Wilfred, This feature is platform-related. Since we don't have a workable device for developing this feature, I would like to remove this user story from 1.4. Moreover, like what I said in comment 2, it is better to have this feature after DSDS EAP_SIM is supported in WAP_Supplicant. Thanks.
blocking-b2g: 1.4+ → 1.4?
Michael, please see comment 9. Can you confirm this is supported in your platform? Thanks 

Steven, same question for you. Thanks
Flags: needinfo?(styang)
Flags: needinfo?(mvines)
Per comment 2 and comment 9, wpa_supplicant effort is on vendor. 
Besides that we'll also have GAIA works to do. 
Should we defer it to 1.5 at this moment?
Flags: needinfo?(wmathanaraj)
UX spec updated
Ken, please verify the latest modem build from our partner.
Flags: needinfo?(styang) → needinfo?(kchang)
(In reply to Steven Yang [:styang] from comment #15)
> Ken, please verify the latest modem build from our partner.
Thanks, but the latest modem build doesn't support DSDS EAP-SIM, right?
It is only for signal SIM. I wonder if you command the wrong bug.
Flags: needinfo?(kchang)
EAP-SIM DSDS for v1.4 will remain as is for v1.3. i have --'d this user story.
blocking-b2g: 1.4? → ---
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(mvines)
Assignee: nhsieh → nobody
blocking-b2g: --- → backlog
Hi Howie, 
The duo SIM support is requested by Woodduck partner. Do we have any plan to implement this in earliest possible version? Thanks!
Blocks: 1087874, 1080481
Blocks: Woodduck
feature-b2g: --- → 2.2?
Duplicate of this bug: 939000
No longer blocks: Woodduck, 1080481, 1087874
No longer blocks: FxOS-v2.2-features
Flags: needinfo?(hochang)
This is not in scope of v2.2
Flags: needinfo?(hochang)
feature-b2g: 2.2? → ---
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.