Closed Bug 947352 Opened 8 years ago Closed 7 years ago

[B2G][Contacts] Magnifying glass search icon on scroll list in contacts app does not function

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, firefox28 affected, b2g18 affected, b2g-v1.2 affected, b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.2 verified)

RESOLVED FIXED
blocking-b2g 2.0M+
Tracking Status
firefox28 --- affected
b2g18 --- affected
b2g-v1.2 --- affected
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: bzumwalt, Assigned: hola)

References

()

Details

Attachments

(4 files)

Description:
In the Contacts app the magnifying glass search icon on the scrollbar to the right does not take user to search field when pressed. If user taps on this icon it highlights as if being pressed, but lacks any other functionality.

Repro Steps:
1) Updated Buri to Build ID: 20131206040203
2) Open Contacts app (with an existing list of contacts)
3) Press magnifying glass search icon on scrollbar


Actual:
Magnifying glass search icon in contacts app not functional.

Expected:
Tapping magnifying glass icon scrolls page up to search field.

Environmental Variables
Device: Buri v 1.3 Mozilla RIL
Build ID: 20131206040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/1401e4b394ad
Gaia: 8fca2ca67e8a6022fe6ed8cb576e5d59dfb5237f
Platform Version: 28.0a1
Firmware Version: V1.2_US_20131115


Notes:
Repro frequency: 3/3, 100%
See attached: video clip - http://www.youtube.com/watch?v=edgrnrBgU8U
I think we should probably attach a screenshot to this bug to show which icon you are talking about - I see what you mean - it is the tiny magnifying icon on the right hand side of the screen.
Attached screenshot showing icon location.

Video is in URL & Comment 0
Does this reproduce on 1.1 & 1.2?
Keywords: qawanted
The bug reproduced on both 1.2 and 1.1. The Search button on the right does not function when the user presses it.

Device: Buri v1.2 Moz RIL
BuildID: 20131209004003
Gaia: f615ae7acb6731d191b3094e10e314bc28359bbb
Gecko: f684b8f159a3
Version: 26.0

Device: Leo v1.1 Moz RIL
BuildID: 20131203041431
Gaia: 19c9ff3a46a4389e40253c97b359763243af4531
Gecko: 617eb9d9bcc2
Version: 18.0
Keywords: qawanted
QA Contact: nkhristoforov
Duplicate of this bug: 1052128
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Assignee: nobody → hola
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
From my point of view we should scroll to search field (top of the list) because users are touching the alpha scroll instead of opening directly the search view. But I would like to know how it should work before Adrian starts implementing this bug. Carrie, any idea/suggestion? Thanks a lot for your support.
Flags: needinfo?(cawang)
Status: NEW → ASSIGNED
Hi, 

To keep it consistent with the behavior of tapping the alphabet indicator, I'd suggest that if users tap the search icon, we scroll the page back to the top where the search field is located (and they can tap the search field to enter the search mode then). Thanks!
Flags: needinfo?(cawang)
OK, thanks for your support. Understood

(In reply to Carrie Wang [:carrie] from comment #7)
> Hi, 
> 
> To keep it consistent with the behavior of tapping the alphabet indicator,
> I'd suggest that if users tap the search icon, we scroll the page back to
> the top where the search field is located (and they can tap the search field
> to enter the search mode then). Thanks!
Attached file 23553.html
After reading how the code works, I came up with this solution. It supposes that the search box will be always on top, but I think it's a fair supposition and I didn't want to make more changes to the code than necessary. Any way, if you think I should try to solve with other approach, please tell me.
Attachment #8482142 - Flags: review?(crdlc)
Comment on attachment 8482142 [details]
23553.html

LGTM although I would like a Fran's review too
Attachment #8482142 - Flags: review?(francisco)
Attachment #8482142 - Flags: review?(crdlc)
Attachment #8482142 - Flags: review+
Comment on attachment 8482142 [details]
23553.html

Tiny nit. Working perfect!
Attachment #8482142 - Flags: review?(francisco) → review+
Nit fixed, I will ask for merge when tbpl is done. Thanks!
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/f354078d45a1edeaa67a64f44c9403fc97f7bebc
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 986034
Tested in 2.2 and magnifying glass search icon in contacts app not functional.
Gecko-ca03f2d
Gaia-73a7ace
What happened? I fixed it so when you use the scroller in the right side of the screen and you scroll to the magnifying glass, the view scrolls to top showing the search box. Tapping it does the same. I've just tested it with the last code from master and everything seems to be working fine.
Flags: needinfo?(lolimartinezcr)
Adrian, just in case check if your patch is already landed here https://github.com/mozilla-b2g/gaia/tree/v2.1
Although Loli says that it is not working on master (2.2). I honestly saw this working fine
(In reply to Cristian Rodriguez (:crdlc) from comment #18)
> Although Loli says that it is not working on master (2.2). I honestly saw
> this working fine

Yesterday when I tested first time I thought the search should be open but I have 
spoken with M.Angeles and she has explained me.

I have retest and it is working,

2.1
Flame
Gecko-52f8689
Gaia-d61264c
Flags: needinfo?(lolimartinezcr)
Attached video verify_video.MP4
This issue has been verified successfully on Flame v2.1
STR:
1. Open Contacts app (with an existing list of contacts).
2. Press magnifying glass search icon on scrollbar.
**It will back to search box field at top of page.
See attachment: verify_video.MP4
Reproducing rate: 0/5
Flame 2.1 versions:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141130001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141130.034738
FW-Date         Sun Nov 30 03:47:49 EST 2014
Bootloader      L1TC00011880
Duplicate of this bug: 1098213
blocking-b2g: --- → 2.0M+
This bug has been successfully verified on Flame v2.2 and woodduck 2.0.
See attachment: verified_v2.2.mp4.
Reproduce rate: 0/5

Flame 2.2 build:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150103.045144
FW-Date         Sat Jan  3 04:51:56 EST 2015
Bootloader      L1TC000118D0

Woodduck 2.0 build:
Gaia-Rev        3954e471652245293b5387e7bc732e52834658e5
Gecko-Rev       bb95bcf5c2033a59b3261b93804151d1addb75eb
Build-ID        20150104050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1420319384
FW-Date         Sun Jan  4 05:10:31 CST 2015
You need to log in before you can comment on or make changes to this bug.