Please have the music app stay open/notification still appearing after playing the last song in the play list

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Music
--
enhancement
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Gaia:     8fca2ca67e8a6022fe6ed8cb576e5d59dfb5237f
Gecko:    http://hg.mozilla.org/mozilla-central/rev/1401e4b394ad
BuildID   20131206040203
Version   28.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
Buri

1. play a song in the music app
2. hit the home button
3. bring down the notification

Actual: After that song, the music app shuts down and shuts down the notification.
Expected/Requesting : after that song is done, the music app stays open and the music control notification is still active.

Comment 1

4 years ago
The music app shouldn't shut down, but once the playback queue ends, the notification will go away because there's nothing you can do with the notification anymore, since the queue is empty. If you'd like the notification to stick around, you can always set the music player to repeat, and it will keep the playback queue full forever.

Comment 2

3 years ago
This is intended behavior -> resolving. If we change our minds later, we can reopen this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.