Bogus sequence in UID FETCH when sending messages

VERIFIED DUPLICATE of bug 97497

Status

--
major
VERIFIED DUPLICATE of bug 97497
18 years ago
10 years ago

People

(Reporter: bugzilla-mozilla-org, Assigned: Bienvenu)

Tracking

({imap-interop})

Trunk
x86
All
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Approximately half the time in recent builds (Linux -sea 2001080806 and
2001081006), I get an alert after sending e-mail that reports a "bogus sequence
in UID FETCH".  It suggests that the mail was sent but not properly copied to my
Sent folder when in fact the send and copy operations have completed
successfully.  This occurs on a fully-patched RedHat 6.2 with UW IMAP RPM
imap-2000c-1.6.0.

I only send plaintext e-mail and haven't tried sending HTML, though it shouldn't
make a difference..
(Reporter)

Comment 1

18 years ago
This also happens, with similar frequency, when sending HTML mail.

Comment 2

18 years ago
*** Bug 97122 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
dup was on NT; OS->ALL
OS: Linux → All
(Reporter)

Comment 4

18 years ago
The same message appears infrequently when switching IMAP folders or (I think)
when filters have moved messages.  The latter case I've only seen when I've left
Mozilla overnight; when I return, the "Bogus sequence" alert is up.  In all
cases, the messages are successfully copied (verified using Pine), although it
sometimes takes a series of navigations between folders to get them to show up
in Mozilla.
(Reporter)

Comment 5

18 years ago
Here's a partial log (from NSPR_LOG_MODULES=IMAP:5), in case it means anything.

14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:CreateNewLineFromSocket:
* 597 FETCH (UID 3774 FLAGS (\Seen))
14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:CreateNewLineFromSocket:
* 598 FETCH (UID 3775 FLAGS (\Seen))
14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:CreateNewLineFromSocket:
* 599 FETCH (UID 3776 FLAGS (\Seen))
14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:CreateNewLineFromSocket:
* 600 FETCH (UID 3777 FLAGS (\Recent \Seen))
14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:CreateNewLineFromSocket:
160 OK UID FETCH completed
14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:SendData: 161 UID fetch
0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,3777 (UID RFC822.SIZE
FLAGS BODY.PEEK[HEADER.FIELDS (From To Cc Subject Date Message-ID Priority
X-Priority References Newsgroups)])
14343[8f7cc48]: orion:S-/local/peterj/imap_folders/Sent:CreateNewLineFromSocket:
161 BAD Bogus sequence in UID FETCH

Comment 6

18 years ago
Confirmed (both for sending and changing folders) on 2001090410, on Solaris 8
on SPARC.
(Reporter)

Comment 7

18 years ago
This is now also appearing, at random intervals, when Mozilla checks incoming
mail on my IMAP server.  In other words, it becomes impossible to see new mail.
 The behaviour is exactly the same--every time an access to the folder is
attempted (via "Get Msg", switching folders, or otherwise) the alert is
displayed.  The only way to get rid of the situation is to exit Mozilla.
Severity: normal → major

Updated

17 years ago
Keywords: interop
(Assignee)

Comment 8

17 years ago
taking, however, I don't know how to reproduce this. I think a more complete log
would be helpful.
Assignee: mscott → bienvenu

Comment 9

17 years ago
this is the same error message that I'm seeing in:
http://bugzilla.mozilla.org/show_bug.cgi?id=40701

I dont this this bug is "interop". I'm seeing the error on my Exchange server.

(Assignee)

Comment 10

17 years ago
are you seeing this in builds since after 10/18/01? Scott checked in a fix that
might also fix this.

Comment 11

17 years ago
I havn't seen this is a couple of days. What fix was that?
(Assignee)

Comment 12

17 years ago
the fix for bug 97497 probably fixed this too. If it keeps working for you,
could you mark this a dup of bug 97497? Thanks!
(Reporter)

Comment 13

17 years ago
That's a good point--hadn't even noticed I wasn't getting the messages.  Since
Henrik isn't either, I'll go ahead and mark it a dup.

*** This bug has been marked as a duplicate of 97497 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
Verified as dup after confirmed with David. Thanks David  :-)
Status: RESOLVED → VERIFIED

Comment 15

17 years ago
*** Bug 110270 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.