Closed Bug 947443 Opened 6 years ago Closed 6 years ago

[music][settings][ringer] Music Notification appears when music app was not opened, but ringer music selection was

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: nhirata, Assigned: dkuo)

Details

Attachments

(1 file)

Gaia:     8fca2ca67e8a6022fe6ed8cb576e5d59dfb5237f
Gecko:    http://hg.mozilla.org/mozilla-central/rev/1401e4b394ad
BuildID   20131206040203
Version   28.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
Buri

1. make sure the music app is closed in the task manager
2. open settings
3. go to sound -> ringer
4. select music app
5. pull down notification

Expected: Music Notification should not appear
Actual: Music Notification appears and controls doesn't produce sound
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Makes the Music Notification kinda busted looking... so I nom'ed it.
blocking-b2g: --- → 1.3?
Component: Gaia::Settings → Gaia::Music
Sounds like we should just hide the music notification when music app is in picker mode.
Assignee: nobody → jpg300
I feel like it will be a simple patch which modifies the music app, so assigning to myself.
Assignee: jpg300 → dkuo
Jim,

I think for this issue we should just hide the controls in the utility tray and lock screen, so the fix is simple which just not to init the communication when music in picker mode, would you please review this? thanks.
Attachment #8346395 - Flags: review?(squibblyflabbetydoo)
This behavior was intentional. It looks like the actual bustage is that the currently-playing song isn't properly reset between invocations of the pick activity. Other than that, everything works ok for me.
Sorry, I hit enter too soon. I think we should try to keep the music comms in pick mode, since users might want to use their Bluetooth remotes (e.g. on their headset) to play the song to sample the ringtone. Then again, I don't have a Bluetooth remote, so I'm not sure how many people would want that. Thoughts?
Actually I was trying to hide the music notification and controls when music is used as a ringtone picker, because the previous and next buttons are disabled in pick activity, the only left function is play/pause.

If we keep the bluetooth remote controls in picker mode, it still sends the previous and next commands which we already disabled, then music will have the extra logic to ignore the previous/next commands, so disable the music communication(AVRCP/IAC) entirely feels like a suitable solution for this scenario, does this make sense? or probably ux can help us on this issue.
Comment on attachment 8346395 [details] [review]
Only init the communication when music is not in picker mode

Alright, I'm convinced. :) We're probably safe removing this.

I have a few comments on Github about the code; r- for now, but I think the general strategy you're using makes sense.
Attachment #8346395 - Flags: review?(squibblyflabbetydoo) → review-
Based on comment5 if we are not resetting the current playing song properly between invocations this is basically a regression issue. 

Dominic Is your patch going to fix that problem as well?
Flags: needinfo?(dkuo)
(In reply to Hema Koka [:hema] from comment #9)
> Based on comment5 if we are not resetting the current playing song properly
> between invocations this is basically a regression issue. 
> 
> Dominic Is your patch going to fix that problem as well?

I think so, my patch will not show the music notification and controls when music is launched as a picker, that means the music notification and controls only indicates the status of the regular music app, so the current playing song should be set properly as usual.
Flags: needinfo?(dkuo)
Comment on attachment 8346395 [details] [review]
Only init the communication when music is not in picker mode

Jim, I have addressed the issues you mentioned on github, would you please review this again? thanks.
Attachment #8346395 - Flags: review- → review?(squibblyflabbetydoo)
Issue related to feature going out in 1.3 -- marking this a blocker
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8346395 [details] [review]
Only init the communication when music is not in picker mode

Looks good! rs=me
Attachment #8346395 - Flags: review?(squibblyflabbetydoo) → review+
Landed on master: 5cc733b7e61c820d00b6e63466cabc4e357eab36
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Uplifted 5cc733b7e61c820d00b6e63466cabc4e357eab36 to:
v1.3: d294a2f5fdb7217432cf887effaafc7768b10518
You need to log in before you can comment on or make changes to this bug.