Closed Bug 947479 Opened 11 years ago Closed 8 years ago

Canvas trips CoreGraphics "Assertion failed: (CGFloatIsValid(x) && CGFloatIsValid(y))"

Categories

(Core :: Graphics, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: assertion, crash, testcase)

Attachments

(2 files)

Attached file testcase
== Using a tinderbox (10.7) build on 10.9 ==

Error: this application, or a library it uses, has passed an invalid numeric value (NaN, or not-a-number) to CoreGraphics API. This is a serious error and contributes to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update.

== Using a local (10.9) build on 10.9 ==

Assertion failed: (CGFloatIsValid(x) && CGFloatIsValid(y)), function void CGPathAddLineToPoint(CGMutablePathRef, const CGAffineTransform *, CGFloat, CGFloat), file Paths/CGPath.cc, line 224.
Attached file crash log
Note that this assertion failure happens in a system library, so it affects both debug and non-debug builds.
Other testcases trip similar assertion failures in:

* CGPathAddLineToPoint
* CGPathAddCurveToPoint
* CGPathAddQuadCurveToPoint
I can't reproduce this locally. Please reopen this bug report if the crash still occurs for you in a current build.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: