Bookmarks list too short and no scrollbar

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Alice0775 White, Assigned: adw)

Tracking

(Blocks: 1 bug)

28 Branch
Firefox 30
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3+])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8344045 [details]
screenshot

STR
Move Bookmarks Widget into PanelUI
Created attachment 8344061 [details]
bookmrksmax.jpg  Bookmarks in PanelUI - browser maximized

See Attached image Bookmarks Star in the PanelUI. The scroll-bar on the bookmarks panel is partly hidden behind the page scrollbar. 

I don't see the list 'cut-off' as noted by Alice. 

If I un-maximize the browser the scroll-bar on the Bookmarks panel display's properly.
(Reporter)

Comment 2

4 years ago
STR
1. Remove all widgets from PanelUI
2. Move Bookmarks Widget into PanelUI
3. Open Bookmarks
Created attachment 8344062 [details]
bookmarks un-maximized.jpg

See attached for Bookmarks PanelUI with browser un-maximized.  

This on win7 with Aero enabled. 

Latest m-c hourly build cset:
https://hg.mozilla.org/mozilla-central/rev/b3806ae5399d
Confirmed, STR in comment #2, I can repo the 'short-list' of Bookmarks.

Updated

4 years ago
Whiteboard: [Australis:P3]

Comment 5

4 years ago
Jim, can you still reproduce this? There've been a couple of fixes to panel placement in the meantime, so I am hopeful this has gone away, but if not we need to investigate further.
Flags: needinfo?(jmjeffery)
(In reply to :Gijs Kruitbosch from comment #5)
> Jim, can you still reproduce this? There've been a couple of fixes to panel
> placement in the meantime, so I am hopeful this has gone away, but if not we
> need to investigate further.

Yes, the jumpiness has gone away, but the list is still to long, and extends below the Windows Taskbar and I cannot even see the 'show all bookamrks' link due to being buried behind the Taskbar. 

The best solution IMO, would be to restore the flyout for Recent Closed Tabs and Recent closed windows thus consolidating the list as it used to do, and as it does now from the Menubar -> History.
Flags: needinfo?(jmjeffery)
Gijs, oops I misread and got this bug mixed up with the History list, please disregard comment #6 and proceed.

I will retest later this evening, my time EST when I get home from work.
(In reply to :Gijs Kruitbosch from comment #5)
> Jim, can you still reproduce this? There've been a couple of fixes to panel
> placement in the meantime, so I am hopeful this has gone away, but if not we
> need to investigate further.

Yes, I can still repo the 'short-list' following the STR in comment #2.

Comment 9

4 years ago
FYI: On linux, bookmark submenus cover the taskbar, even if not full height.
Is this a bug?
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20140120132616 CSet: c1ef58534e98

Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140121063910 CSet: 1b52aa569ced

Comment 10

4 years ago
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #8)
> (In reply to :Gijs Kruitbosch from comment #5)
> > Jim, can you still reproduce this? There've been a couple of fixes to panel
> > placement in the meantime, so I am hopeful this has gone away, but if not we
> > need to investigate further.
> 
> Yes, I can still repo the 'short-list' following the STR in comment #2.

So the weird thing is that we have both this bug filed and bug 963078. It seems weird that both happen. :-\
(In reply to :Gijs Kruitbosch from comment #10)
> (In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #8)
> > (In reply to :Gijs Kruitbosch from comment #5)
> > > Jim, can you still reproduce this? There've been a couple of fixes to panel
> > > placement in the meantime, so I am hopeful this has gone away, but if not we
> > > need to investigate further.
> > 
> > Yes, I can still repo the 'short-list' following the STR in comment #2.
> 
> So the weird thing is that we have both this bug filed and bug 963078. It
> seems weird that both happen. :-\

Bug 963078 happens mostly with the history menu (which extends all the way to the bottom). But it really affects the entire panel and any of its subviews (when the window is moved to the bottom or the screen is small).
Whiteboard: [Australis:P3] → [Australis:P3+]
(Assignee)

Comment 12

4 years ago
As far as I can tell, the problem is simply that there's nothing telling panelMenu_bookmarksMenu to be at least a certain height, nor apparently its ancestor nodes.

Gijs, I can write a patch that sets a min-height or removes its flex=1, but I'm guessing it's more complicated than that.  (Like, we don't want the panel to grow past the edge of the screen.)  It looks like the bookmarks menu is unique, and there are no other widgets that expand into menu subviews in the panel, so there's no precedent for me to go on.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 13

4 years ago
(In reply to Drew Willcoxon :adw from comment #12)
> As far as I can tell, the problem is simply that there's nothing telling
> panelMenu_bookmarksMenu to be at least a certain height, nor apparently its
> ancestor nodes.
> 
> Gijs, I can write a patch that sets a min-height or removes its flex=1, but
> I'm guessing it's more complicated than that.  (Like, we don't want the
> panel to grow past the edge of the screen.)  It looks like the bookmarks
> menu is unique, and there are no other widgets that expand into menu
> subviews in the panel, so there's no precedent for me to go on.

I'm confused. There are several other widgets, such as the history subview and the character encoding subview. I don't know why they don't have the problem and the bookmarks one does, because AFAIK we use toolbarbuttons for the bookmarks menu as well, when it's used as a subview in the menupanel...
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Comment 14

4 years ago
Created attachment 8374349 [details] [diff] [review]
don't flex panelMenu_bookmarksMenu

Thanks for pointing out the other two similar subviews.  I overlooked them.

Maybe I'm missing something, but it looks like panelMenu_bookmarksMenu simply shouldn't flex.  PanelUI-historyItems and PanelUI-characterEncodingView's various vboxes don't flex.  And it doesn't look like there's any special handling required to prevent the panel from growing past the edge of the screen, and indeed with this patch the bookmarks subview scrolls when necessary.
Attachment #8374349 - Flags: review?(gijskruitbosch+bugs)

Comment 15

4 years ago
Comment on attachment 8374349 [details] [diff] [review]
don't flex panelMenu_bookmarksMenu

Review of attachment 8374349 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, ship it!
Attachment #8374349 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 16

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/c3d4784309df
Assignee: nobody → adw
Status: NEW → ASSIGNED

Comment 18

4 years ago
(In reply to Drew Willcoxon :adw from comment #17)
> Backed out for possibly causing bc test failures on Windows only:
> https://hg.mozilla.org/integration/fx-team/rev/1ae495a16414
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=34518905&tree=Fx-Team
> https://tbpl.mozilla.org/php/getParsedLog.php?id=34518699&tree=Fx-Team
> https://tbpl.mozilla.org/php/getParsedLog.php?id=34519157&tree=Fx-Team

And relanded because I'm pretty sure this was bug 969376's fault instead:

remote:   https://hg.mozilla.org/integration/fx-team/rev/0dbaff20d440
Whiteboard: [Australis:P3+] → [Australis:P3+][fixed-on-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0dbaff20d440
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3+][fixed-on-fx-team] → [Australis:P3+]
Target Milestone: --- → Firefox 30
status-firefox29: --- → fixed
status-firefox30: --- → affected
status-firefox29: fixed → affected
status-firefox30: affected → fixed

Comment 20

4 years ago
Comment on attachment 8374349 [details] [diff] [review]
don't flex panelMenu_bookmarksMenu

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: Bookmarks toolbar button menu doesn't display correctly
Testing completed (on m-c, etc.): on m-c for a week
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8374349 - Flags: approval-mozilla-aurora?
Attachment #8374349 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 22

4 years ago
Test day 24/2/2014

validated the bug in Aurora B29 and Nightly B30 

It is resulting as expected, I can see the scroll bar properly displaying

Updated

4 years ago
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.