Make TabsProvider extend TransactionalProvider

RESOLVED DUPLICATE of bug 986114

Status

()

Firefox for Android
Data Providers
RESOLVED DUPLICATE of bug 986114
4 years ago
3 years ago

People

(Reporter: Margaret, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
At the very least these trace/debug methods should be moved into something like DBUtils.java. However, I see the background package has it's own Logger utility, and I wonder if we could upgrade our logging to use that instead:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/background/common/log/Logger.java
Flags: needinfo?(rnewman)

Updated

4 years ago
Summary: Consolidate copy/pasted logging logic in BrowserProvider/TabsProvider → Make TabsProvider extend TransactionalProvider
I took care of this in Bug 986114. No more duplication!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(rnewman)
Resolution: --- → DUPLICATE
Duplicate of bug: 986114
You need to log in before you can comment on or make changes to this bug.