Closed Bug 947615 Opened 8 years ago Closed 7 years ago

Event description shows escaped comma and line breaks

Categories

(Calendar :: ICAL.js Integration, defect)

x86
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: clokep, Assigned: MakeMyDay)

References

Details

(Whiteboard: [calconnect31-haspatch])

Attachments

(2 files, 1 obsolete file)

Attached image unescaped-tooltip.png β€”
This has been happening for a little while now, but I couldn't find a bug filed on it. I have a CalDAV calendar set up with Google Calendar on trunk Thunderbird and Lightning. When I create an event with a description, the description comes back with commas escaped (as \,) and line breaks as \n. See the attached screenshot of a tooltip. (Note that the commas in the Location field are also escaped.)

This is exhibited for both events created in Google Calendar itself and in Lightning. But viewing these events in Google Calendar doesn't show any issues.
Whiteboard: [calconnect31]
On a CalDAV calendar it is not just the tooltip but also the information in event dialog which is displayed in that way, while this does not happen for local calendars. Additionally, e-mail invitation are also displayed with the escaped characters.

This happens only, if ical.js is enabled - with libical, everything is displayed as expected. So, it seems to be an ical.js issue.
Component: Provider: CalDAV → ICAL.js Integration
Attached patch WiP - v1 (obsolete) β€” β€” Splinter Review
Confirmed and issue found. Since at the time I didn't exactly remember what valueAsIcalString does I just implemented the value property and forwarded the other one. Here is what is supposed to happen:

* get value gives you the unescaped string
* get valueAsIcalString gives you the escaped string

The setters behave the same way, which I have not fixed yet. See the failing test case. MakeMyDay, any chance you can pick up on this?
Whiteboard: [calconnect31] → [calconnect31-haspatch]
Yes, I'll take this.
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Updated patch based on your one. Setters are added. Text is not displayed escaped anymore and tests passed on try-comm-central.
Attachment #8498007 - Attachment is obsolete: true
Attachment #8500149 - Flags: review?(philipp)
Attachment #8500149 - Flags: review?(philipp) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/98ee5d8c976a
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 3.8
Geoff, check out this bug regarding your comment in IRC. There needs to be a difference between value and valueAsIcalString. I never really know which is which though and why we really need them both.
Duplicate of this bug: 1130603
You need to log in before you can comment on or make changes to this bug.