Closed Bug 94765 Opened 20 years ago Closed 16 years ago

"Delete" goes to next thread instead of next *in* thread and preference is "mark as deleted")

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla-bugs, Unassigned)

References

Details

When I use "Delete" in threaded view, it advances to next thread instead of
advancing to next message in the current thread.

Reproducible: always
Steps:
1) Configure an Imap server with "mark as deleted" deletion method (do not
forget to restart Mozilla if you change deletion method).
2) Select threaded view in 3-pane window.
3) Highlight a root message in *collapsed* thread
4) Press "delete".

Expected: Message marked as deleted and the next (non-deleted) message in thread
gets displayed (with thread being expanded as necessary).

Actual: Message marked as deleted and the root message in next thread gets
dispalyed.

Note that is the original thread is expanded before deleting, everything works OK.

I am seing this on 0.9.2 on RedHat 7.1. I haven't tried it with newer versions
or other IMAP deletion models or non-Imap folders, so I am filing it as unconfirmed.
Happens with IMAP delete model - Mark as Deleted.
Doesn't happen when using Move to Trash.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → sheelar
*** Bug 114794 has been marked as a duplicate of this bug. ***
Karen,
Imap delete model
I was wondering you probably have a known bug on this 
QA Contact: sheelar → huang
*** Bug 160432 has been marked as a duplicate of this bug. ***
Is that really what you expect to happen?  I would have expected the behaviour
you see.  If I wanted it to go into the next level down in the heirarchy, I
would have had the thread expanded.  I would have actually expected the thread
to be marked deleted in it's entirety (but that's something else altogether)

Cheers,
Karl P
> Is that really what you expect to happen?

Yes - "Delete" is very often used as a substitute for "Next" when you are
reading mail (such as mailing list traffic) that you are interested in, but do
not want to keep around.

P.S. In BuildID 2002111123 (trunk), delete model "move to Trash" this works
correctly.
Isnt this fixed?
Blocks: 236849
Product: Browser → Seamonkey
Assignee: sspitzer → mail
(In reply to comment #7)
> Isnt this fixed?

WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050917
SeaMonkey/1.1a  (when options set to "mark as deleted")

and OS=ALL per Bug 114794
OS: Linux → All
Hardware: PC → All
Summary: "Delete" goes to next thread instead of next *in* thread → "Delete" goes to next thread instead of next *in* thread and preference is "mark as deleted")
WFM (but I'm sure there was a fix some ways back) 
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.