Thread pane columns: Display, Remove, Add not working properly

VERIFIED FIXED in mozilla0.9.4

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: laurel, Assigned: sspitzer)

Tracking

Trunk
mozilla0.9.4
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using aug10 commercial trunk build: win98, mac OS 9.0, linux rh6.2
Modern and classic themes

Removing and displaying 3-pane mail window thread pane columns is not working
properly.  

1.  Adding columns may or may not actually add them to display.  If they are
added they often will not refresh the display and the data from a neighboring
column will be shown under the new heading.  Usually cleared upon switching to
another window and back.
2.  Removing columns does the same kind of thing. Removed column will cause the
other columns to have mismatched data to column heading.
3.  All columns checkmarked in the show/hide column widget dropdown are not
present in the thread pane.

Steps:
1.  Select inbox or other populated folder.
2.  Click the column display widget in right corner of thread pane.
3.  Check to see if all the columns are displayed: not.  Even if you resize the
columns to be smaller, some columns which are checkmarked do not display.
4.  Uncheck a column or two.  Check thread pane display: mismatched data to
column headings.
5.  Check a column or two to add it back to display:  may or may not be added,
if so, check data to column heading and it is likely mismatched.
(Reporter)

Updated

17 years ago
QA Contact: esther → nbaca
(Reporter)

Comment 1

17 years ago
Oh, and this happens in either existing or new profiles.

Updated

17 years ago
Keywords: nsBranch
(Reporter)

Comment 2

17 years ago
This is also affecting search messages' results pane columns.
I just checked in a fix for the first two problems.

now, after the toggle state changes, we invalidate the outliner.

I'm investigating the third.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.4

Comment 4

17 years ago
95164 may seem like a dup but 95164 also reports similar problem for the history
window
blake backed out his change to outliner.xml, and these problems are gone.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Build 2001-08-15-04: WinMe
Build 2001-08-15-08: Mac 9.04, Linux RH 6.2
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.