Use clear version identifier for used virtualenv version

RESOLVED WORKSFORME

Status

Testing
Marionette
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

With the landing of the patch on bug 943240 we are using a pinned version of virtualenv for Marionette now. This is done via:

+VIRTUAL_ENV_VERSION="49f40128a9ca3824ebf253eca408596e135cf893"

I call this very hard to read and to identify which version it actually is. So we should replace it with the real version like '1.9.1'. 

Also keep in mind that the above specified version is somewhat not an official release given that it refers to '1.8.4.post1'.
Jonathan, is there anything which would block us from doing this change and upgrade to 1.9.1? We can't use later version of virtualenv for now given that you will have to download and extract the whole archive of virtualenv.
Flags: needinfo?(jgriffin)
I think using 1.9.1 would be fine.
Flags: needinfo?(jgriffin)
is this a marionette issue or can it be moved over to another component?
Flags: needinfo?(hskupin)
Interestingly the venv_automation.sh bash script does no longer exist. Not sure which patch/bug actually removed it. It's not visible in the revision list:

https://hg.mozilla.org/mozilla-central/log/default/testing/marionette/client/marionette/venv_automation.sh

I would call it WFM.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(hskupin)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.