Closed Bug 947856 Opened 6 years ago Closed 6 years ago

Regression: Bug 855208 Removed the Check of Muting Background Content Channel by Video with Normal and in Foreground

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, firefox27 wontfix, firefox28 fixed, firefox29 fixed, b2g-v1.2 fixed, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C1/1.4 S1(20dec)
blocking-b2g koi+
Tracking Status
firefox27 --- wontfix
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.2 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: mchen, Assigned: brsun)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Bug 855208 introduced a regression of

  A foreground video (ex: youtube) can't mute background content channel which is on playing.

The improved way of this is to add test case into testAudioChannelService.cpp
Hi Steven,

The user impact of this is

 When user watch the video via browser or youtube app, the background music will not be paused automatically.

This behavior is confirmed by Bug 894249.
blocking-b2g: --- → fugu?
Will it impact v1.2 as well?
Flags: needinfo?(mchen)
Reset mPlayableHiddenContentChildID as CONTENT_PROCESS_ID_UNKNOWN to mute any content channel in background if there is any normal channel with video in foreground.
Attachment #8345210 - Flags: review?(mchen)
We'll need it for koi?
blocking-b2g: fugu? → koi?
triage: regression on 1.2. koi+
blocking-b2g: koi? → koi+
Duplicate of this bug: 948760
Comment on attachment 8345210 [details] [diff] [review]
bug947856_background_content_and_foreground_normal.patch

The unit-test, TestOneVideoNormalChannelAndOneContentChannel(), does not run in main().
Attachment #8345210 - Attachment is obsolete: true
Attachment #8345210 - Flags: review?(mchen)
(In reply to Steven Yang [:styang] from comment #2)
> Will it impact v1.2 as well?

Yes, it is.

When user watch the video from youtube, the background music can't be paused automatically.
Flags: needinfo?(mchen)
This patch is based on attachment 8345210 [details] [diff] [review]. Rename the test cast to a short one, and add the test cast into main() of the test program.
Attachment #8345788 - Flags: review?(mchen)
Comment on attachment 8345788 [details] [diff] [review]
bug947856_background_content_and_foreground_normal.v2.patch

Review of attachment 8345788 [details] [diff] [review]:
-----------------------------------------------------------------

It looks good to me. Thanks.
Attachment #8345788 - Flags: review?(mchen) → review+
Duplicate of this bug: 949834
Keywords: regression
Ready for check-in. Add reviewer information in the commit log.
Attachment #8345788 - Attachment is obsolete: true
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bac23ed0f7f8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/17141bcf340a

In my queue for b2g26 once it reopens.
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
You need to log in before you can comment on or make changes to this bug.