Closed Bug 947859 Opened 8 years ago Closed 8 years ago

Settings menu has stopped working in Contacts app for B2g desktop

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

Other
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zcampbell, Assigned: arcturus)

Details

Attachments

(1 file)

JavaScript error: app://communications.gaiamobile.org/contacts/js/views/settings.js, line 82: orderCheckBox is undefined

STR:
1. Download/unpack a tinderbox desktopb2g
2. Generate a gaia profile
3. Load b2g with the profile:
b2g -profile $GAIA/profile/
4. After startup, load Contacts app
5. Tap settings
6. Note the exception in the console.



This was replicated using a Tinderbox build with ID 20131209000359.
Can this reproduce on a production device on 1.3?
Keywords: qawanted
Not able to reproduce on Buri using today's nightly build.
Keywords: qawanted
This seems to be a desktopb2g only bug.

Here is a simpler STR:
1. Download this build: http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2013-12-10-04-02-06-mozilla-central/
2. Unpack
3. Load ./b2g.sh
4. Navigate through the FTU
5. Open the Contacts app, tap 'Settings'
6. Note the exception in the log
Only B2G issue, when we added the support for DSDS we didn't have into account the desktop version.

Taking it, Zac is this bug preventing the launch of gaia ui tests I guess, is it critical?
Flags: needinfo?(zcampbell)
Summary: Settings menu has stopped working in Contacts app → Settings menu has stopped working in Contacts app for B2g desktop
Assignee: nobody → francisco.jordano
It is weird; this test is working fine on Travis but if you follow the steps from comment #3 it is replicable. 

It's not critical but I wonder if it represents something a bit weird in the way different profiles with touch/click activity are handled by this button.
Flags: needinfo?(zcampbell)
:zac, this is related to the work we did in DSDS and the new iccmanager.

Sending patch in 3,2,1 ...
Attached file patch v1
Attachment #8349476 - Flags: review?(jmcf)
Comment on attachment 8349476 [details] [review]
patch v1

thanks for the patch
Attachment #8349476 - Flags: review?(jmcf) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/b7b5e196969b9456e1ec84b83664a02670fe8623
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.