[Cost Control] Settings are broken and unusable

RESOLVED FIXED in Firefox OS v1.3

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: salva, Assigned: mai)

Tracking

({regression})

unspecified
1.3 C1/1.4 S1(20dec)
x86_64
Linux
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

Attachments

(1 attachment)

STR

0. With a data usage only SIM (i.e, not Vivo, not Venezuela, not Colombia)
1. With the latest in master, make reset-gaia
2. Open Cost Control
3. Pass the FTU

Now, due to bug 945469 it is impossible to pass the FTE  but you can close and reopen the application.

4. Open settings

Expected:
Settings is displayed properly.

Actual:
Settings is displaying a broken drop-down menu and it is unusable.
We need QA in order to see if this is affecting 1.2.

I tested with the latest Usage application in master but I tested it even before landing bug 944718 (commit 091161997bebfc0c2d053339b1c9891c57216920) and it is reproduced as well.

I'm afraid this could be a Gecko issues related with async / defer load modes for scripts in addition to some wrong assumptions we are making on the Gaia side so, we are solving the Gaia side just right now.

What do you think, Jason?
Flags: needinfo?(jsmith)
(Assignee)

Updated

5 years ago
Assignee: nobody → mri
(Assignee)

Comment 2

5 years ago
Created attachment 8344583 [details]
patch v1.0

Please, could you review my code?
Attachment #8344583 - Flags: review?(salva)
Comment on attachment 8344583 [details]
patch v1.0

It is working perfectly now. Wait for Travis before merging.

Thank you Marina!
Attachment #8344583 - Flags: review?(salva) → review+
Travis is green [1] but the tree is still closed.

[1] https://travis-ci.org/mozilla-b2g/gaia/builds/15166080
I'll get someone to check if this reproduces on 1.2 today.
Flags: needinfo?(jsmith)

Updated

5 years ago
QA Contact: gbennett

Comment 6

5 years ago
Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131209004003
Gaia: f615ae7acb6731d191b3094e10e314bc28359bbb
Gecko: f684b8f159a3
Version: 26.0
Firmware Version: 20131115

This does not repro on the latest 1.2
Keywords: qawanted

Updated

5 years ago
Keywords: regression, regressionwindow-wanted

Comment 7

5 years ago
This does not repro on the latest 1.3 and 1.2, should a regression window still be found?

Latest 1.3
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131209053402
Gaia: 1d45d1dc3201059d5c8f2efdeb92c04576d8e161
Gecko: 9f12a9fab080
Version: 28.0a1
Firmware Version: 20131115
Flags: needinfo?(jsmith)
Probably not. We should find out why we can't reproduce.

Salva - Can you double check this? We can't reproduce this in house.
blocking-b2g: 1.3? → ---
Flags: needinfo?(jsmith) → needinfo?(salva)
Keywords: regression, regressionwindow-wanted
(Assignee)

Comment 9

5 years ago
 Master: 012f11bc56c949ad9e9df399c57448a8436d1448
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
I double checked it and it is reproducible in our builds. Anyway, this bug have a very low risk and improve performance by using lazy load. Please, consider to include in 1.3. What do you think?
blocking-b2g: --- → 1.3?
Flags: needinfo?(salva) → needinfo?(jsmith)
Comment on attachment 8344583 [details]
patch v1.0

Despite solving a bug, this patch fixes a wrong assumption about `async` and `defer` load modes and, in addition, improves the performance.

[Bug caused by] (feature/regressing bug #): --
[User impact] if declined: medium (worse performance) to hight (if bug reproduced)
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8344583 - Flags: approval-gaia-v1.3?
(In reply to Salvador de la Puente González [:salva] from comment #10)
> I double checked it and it is reproducible in our builds. Anyway, this bug
> have a very low risk and improve performance by using lazy load. Please,
> consider to include in 1.3. What do you think?

That sounds fine.
Flags: needinfo?(jsmith)
Keywords: regression

Updated

5 years ago
status-b2g-v1.3: --- → affected

Updated

5 years ago
Attachment #8344583 - Flags: approval-gaia-v1.3? → approval-gaia-v1.3?(francisco.jordano)
Comment on attachment 8344583 [details]
patch v1.0

In behalf of Salvador, since he is the owner of Cost Control but doesn't appear in the drivers list: a+

Based on comment 11.

Cheers,
F.
Attachment #8344583 - Flags: approval-gaia-v1.3?(francisco.jordano) → approval-gaia-v1.3+
Hi John,

Could you help us with the uplift to v1.3 branch?. Thanks!
Flags: needinfo?(jhford)
triage: 1.3+ regrsesion
blocking-b2g: 1.3? → 1.3+

Updated

5 years ago
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
[v1.3 66ab7aa] Bug 947865 -[Cost Control] Settings are broken and unusable
status-b2g-v1.3: affected → fixed
Flags: needinfo?(jhford)
You need to log in before you can comment on or make changes to this bug.