Closed Bug 947883 Opened 6 years ago Closed 5 years ago

Firefox with Adblock Plus 2.4 installed can't be started after closing

Categories

(Firefox :: Untriaged, defect, major)

25 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: heletjacq.graves, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

Install Firefox 25.0.1 and add Adblock Plus 2.4,
Without AdBlock Plus : Firefox can closed then restarted,
After addition of AdBlock Plus 2.4 and "private web", Firefox cannot be restarted : Error message on new launch of Firefox.


Actual results:

If I close Firefox, the Firefox windows is closed.
If I re-launch Firefox : error message" "Before launch Firefox close the process or reboout your system 


Expected results:

Normal restart of Firefox
Severity: normal → major
Did you test with a clean profile and only this add-on?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Blocks: abp
Flags: needinfo?(heletjacq.graves)
Summary: Firefox could not be started after closing → Firefox with Adblock Plus 2.4 installed can't be started after closing
Many thanks for your prompt reply.
I made the following :
- 1) unistall Firefox and delete profiles according https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles,
- reinstall Firefox without Adblock Plus and restart Firefox : All is Ok, Firefox can be closed and re-opened normally,
- reset parameters to "Use private"  : all is OK
- modify parameters fur "Use personnal rules" and restart Firefox : all is Ok,
- add Adblock Plus and keep "Use parsonnal rules ": All is Ok,
- change "use personnal rules" to "Private" and restart Firefox : then Firefox cannot be re-opened and the "Windows process manager" must be used to kill Firefox.
Is these informations clear for you to reproduce the malfunction of Firefox with AdBlock Plus 2.4 ?
Flags: needinfo?(heletjacq.graves)
"Use private", what's that? An option in ABP or in Firefox?
In french "Toujours utiliser le mode de navigation privée", I try to translate "Always use the private mode for the navigation". You may obtain this by the following way :
- Options > Options > Vie privée > then tick the option "Toujours utiliser le mode de navigation privée".
This is a Firefox parameter not an ABP parameter
The same bug appeared with Firefox 26.0 :
- same settings for Firefox (Private Life, Always use private navigation mode).
Additionnal informations : the bug is random, it appears after several open and close of Firefox (about 5 times). It diappears when Adblock Plus 2.4 is uninstalled and reappeared when Adnlock Plus 2.4 is reinstalled.
I did a quick test to see whether I can reproduce that issue - I cannot, Firefox shuts down correctly (testing with "Always use private browsing mode" setting switched on and Adblock Plus 2.4.0.3745, Firefox 25 and 29.0a1 2013-12-14 nightly, Linux x64). Frankly, I didn't really expect this to be easily reproducible: there are enough Adblock Plus users always using private browsing mode for this issue to be prominent if it were indeed reproducible. Given that I've never heard of this issue before, there must be something else involved beyond Adblock Plus and that setting.
Many thanks for your anwser and quick (probably short) test with Adblock Plus and "Always use private browsing mode".
- 1) after a quick web research I discovered that a lot of people encounter the same problem with Firefox 25.0.1 and Adblock Plus,
- 2) the problem is very easily reproducible with Firefox 26.0, Adblock Plus 2.4 and Windows 7 SP1 64 bits (updated),I did not try Linux 64 that you tested,
- 3) the problem does not occurs neither with "use personnal settings with "historics", nor with Firefox default settings and appears only after several opening and closing of Firefox (about 5 to 10 times), not after a new install and the first opening and closing,
- 4) I never encountered this problem with Firefox 24 or previous releases,
- 5) after some web research I discovered that some years ago (2007 to 2009) encourentered the same problem ans had to close Firefox with "Killing Firefox.exe 32 Process".
I hope you will find the cause of this problem.
Is this still an issue ?
Flags: needinfo?(heletjacq.graves)
no response
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(heletjacq.graves)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.