[Australis] When placed on glass Sync button has wrong (dummy) icon while syncing

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Theme
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Thomas Stache, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 29
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8344629 [details]
screenshot of syncing/default button states

During syncing the "Sync" toolbar button shows the wrong icon (the dummy fallback icon).

Related: bug 940844, bug 940046.
(Reporter)

Updated

5 years ago
Version: unspecified → Trunk
Blocks: 872617
Whiteboard: [Australis:P3]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940844
I agree these are different issues, so I'm unduping. This is about the glass selector overriding the 'busy' selector in the tabstoolbar on win7/8. The other bug is about the menu panel not having a high-quality icon for busy state.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Created attachment 8366876 [details] [diff] [review]
fix sync button pending state on Australis win7 glass on menubar/tabstoolbar,
Attachment #8366876 - Flags: review?(mdeboer)
Assignee: nobody → gijskruitbosch+bugs
Status: REOPENED → ASSIGNED
Comment on attachment 8366876 [details] [diff] [review]
fix sync button pending state on Australis win7 glass on menubar/tabstoolbar,

Review of attachment 8366876 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #8366876 - Flags: review?(mdeboer) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/35f758e7ac6a

With [cui-areatype="toolbar"] because I realized that otherwise this would break things in the menu panel...
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/35f758e7ac6a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 29

Updated

4 years ago
QA Contact: cornel.ionce
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:30.0) Gecko/20100101 Firefox/30.0

Issue verified fixed on Windows 7 64-bit using:
- the latest Aurora (Build ID: 20140310004003),
- the latest Nightly (Build ID: 20140310030201).
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

4 years ago
Steven, is the correct icon used for the active Sync button? It looks like the normal state has a new icon, which has more slanted arrow ends, while the animated version has the old straight ends.
Flags: needinfo?(shorlander)
(In reply to Thomas Stache from comment #8)
> Steven, is the correct icon used for the active Sync button? It looks like
> the normal state has a new icon, which has more slanted arrow ends, while
> the animated version has the old straight ends.

We are updating them all for consistency. New Sync throbbers will be implemented in bug 940844. Thanks!
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.