bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Status

SeaMonkey
General
--
enhancement
RESOLVED WONTFIX
17 years ago
14 years ago

People

(Reporter: raccettura, Assigned: raccettura)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

17 years ago
For those with kids, how about adding a word filter?

For example, "bad words" could be stored in a text file and if the feature is 
enabled, Mozilla would compair the URL and the text in the page against the list.  
Obviously this should be an option disabled by default in the preferences since 
it would slow down Mozilla.

Comment 1

17 years ago
hmmm.  built in censorware.  I'm afraid that will probably go down like a lead
balloon with most of the moz community.  

That kind of blocking can be a PITA, too.  Anyone wanting to read about the
British seaside resort of Scunthorpe will get rather annoyed, to pick a famous
example.

If it has to be manually configured (i.e. list of words compiled) by the user,
no-one will use it.  If the list is compiled centrally, there will be a flamewar
of gargantuan proportions over what words go into the list.
(Assignee)

Comment 2

17 years ago
What I was thinking is that a few words are put in by default, and a user 
manually must enable it.  DON'T PUT IT ON BY DEFAULT, because then it is 
censorware.  But it should be an option for those who need this type of feature.  
If somebody wants, maybe a company will publish a monthly download containing 
keywords to block, but that is 3rd party.  Mozilla should just be able to block 
what the owner wants blocked.

Is the filter feature in Mail any different?  It's the exact same thing in 
essence... should we remove that?  It's also censorware!  It just makes life 
easier for some.  

Comment 3

17 years ago
This bug was filed on me and I'm certainly not going to implement it. 
robert@accettura.com if you intend to attach a patch that makes this happen and
think you can get it though review and super-review go for it.  
Assignee: asa → robert

Comment 4

17 years ago
would you want to have words ****'d, dropped, or just block the entire page?
(Assignee)

Comment 5

17 years ago
I didn't really think that far... but why not make that an option?  **** is a 
good idea, but if a parent wants to keep a child away from porn sites, *** is not 
an acceptable solution in that case.


I don't mean for this to be censorware, but to be an enhancement for parents, if 
they had a free way to block or restrict what a child could see, Mozilla will be 
the browser of choice for parents.

It's not really  censorware if you think about it... It should be off by default, 
and doesn't need to contain a "dirty words list"... many of those already exist, 
and we could just make that a separate download from a third party... so it's not 
censoring anything without the users concent, it alows the user to decide what 
they want to see.  Like a firewall can protect their computer from people they 
don't want to have access to their computer... is that censorware?
There are third-party software packages that do this sort of thing, aren't
there? I'm not sure we need the bloat of a content filter when alternatives exist.
(Assignee)

Comment 7

17 years ago
Third parties do perform these tasks, but most are paid services, and use a 
database of words or URL's that are maintained by a corporation.  And normally, 
you can't even see what the software will block... they only say "bad stuff."

If the basis for this was implemented as open source in the Mozilla web browser, 
anyone could create a database of words, thus preventing some corporation from 
saying what is bad or ok.  The actual user can decide, or they can download a 
list of words as a text file, and decide what to block.  

Really by implementing it as part of open source Mozilla, it is defeating 
censorware since the user gets to decide what to censor based on what they don't 
want to see.  Commercial software, the corporations decide what we don't want to 
see.
Robert, I agree with you about the benefit of users being able to select their
own blocking lists. I was planning to do something like this, though it'll be a
while before I get to implementing anything like this. I had in mind a filter
and collaborative blacklisting mechanism not for "bad words" but for popup
images and other annoying content, or for whole sites we want blocked. There's
no reason why we couldn't add word filtering to that list, as well.

I'm in support of this feature, but as I said I won't be implementing it any
time soon. If you want to take a crack at it, or know someone who does, then
help yourself.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

17 years ago
Here is what I was thinking in more detail:

Here is what I think the data file should look like:

<?xml version="1.0"?>
<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
<wordfilter>
<name>BadWords</name>
<version>1.0.1</version>
<updateurl>ftp.accettura.com/badwords/badwords.xml</updateurl>
<updatesch>monthly</updatesch>
</wordfilter>
<item>
<word>ass</word>
<type>profanity</type>
<severity>medium</severity>
<limit>multiple</limit>
</item>
<item>
<word>dick</word>
<type>profanity</type>
<severity>low</severity>
<limit></limit>
</item>
</rdf:RDF>


Plain text so it's easy to edit by anyone and is truely cross platform.

Version and Update URL so Mozilla can have a button to check for updates, and <
updatesch> so that Mozilla can say "it's time to get an update"  Title so that 
user knows what bad word file they are using.

Each word is done as follows:

<word>ass</word>


This is the actual word to block


<type>profanity</type>


Each word should be catagorized as "profanity" or "sexual" etc so that users can 
say block "sexual" etc.  


<severity>medium</severity>

This is of course the opinion of the writer, but severity is a good thing.  
Something like "butt" is normally not offensive, but it may be to schools, "ass" 
is a little more offensive in general, so it is medum, at least that is how I 
classified it for the example.

<limit>multiple</limit>

to prevent things such as "Scunthorpe" you can use the <limit> tag.  When set to 
"multiple> it will only block the word when multiple "bad words" are found in the 
document.  In 99% of the cases, bads words are found in groups.  We could also 
introduce it so that a word is " word " (with the space before and after so it 
doesn't see words in words).


Mozilla should have the option to block pages with the content, or to put stars *
**** where the word is.  Mozilla should be able to "pick and choose" words on the 
list, or just select a category such as "sexual" on the list.


Of course this is just an idea at the time, and i haven't really finished this, 
but it's just to show that it should be a flexible solution.  If needed I am more 
than willing to write a white paper with how the formatting of the document 
should go and what tags do what and what options can be done.
(Assignee)

Comment 10

16 years ago
Well, I thought I would stir this up again.  I think it is an essential part of 
the Mozilla project making it's way into consumer products.  With the rumor of 
AOL using Gecko across the board, Netscape possibly starting to gain some ground.  
I think it is time to allow for filtering for any purpose.

I personally much prefer specifying my own list of worlds (or HTML tags etc.) to 
block, and how to block it (whole page, or "***") rather than have someone else 
do it.  Mozilla in one form or another needs to become a consumer product before 
anyone will it for a commercial product.  

I don't believe in censorship (just ask my teachers, they would tell you a few 
stories) but I do believe that a parent should block something from their child 
if they wish.  I think it should be the parent making the decision rather than 
paying someone to decide what is good or bad.  My computer, I want to choose.  

By using XML like I specificed before, it could be very possible for an open 
source list of words, and a simple viewer could let parents see what is being 
blocked (something most comercial products don't have.)

Lets not let parents resort to keeping children off of the Internet.  The 
Internet has more benefits than downsides, and we all know that.  The goal should 
be for a parent to have the ability to ensure that children see the good over the 
bad.  And what is "good" should be up to the parent, not a company.

Comment 11

16 years ago
I don't think a mere list of words is enough. Probably need something more
complex, like regEx strings, but then the feature won't be accessible to the
mere mortals.

Still, even if the feature is implemented, filtering out unwanted content on
your own will remain a lost cause. You're better off relying on a third party
service that employees a team of dedicated, overworked, agonized content screeners.
(Assignee)

Comment 12

16 years ago
It may be a job for content screeners, but it would be possible for a person to 
create a block, or share lists, or edit commercial lists.  It would open source 
censorship.  You no longer have all or nothing.
As I said last year, I think there's some sort of collaborative solution that's
both easy to use and doesn't depend on a paid service. However, I don't know who
has the resources to implement this right now. So, as before, I'm in support of
this feature if someone volunteers to code it. Robert, you might want to post at
mozdev.org or mozillazine.org and see if you can find someone who wants to work
on this.

Comment 14

16 years ago
I like this idea, because I have four kids myself. School is using mozilla as
the  default browser, don't ask me how that happened :-) So Robert, count me in.
I will try to help you where ever I can. And good luck with your mozdev.org project.

Hey Mitchell, isn't there already a mechanism build into mozilla to block sites
(stored in a pref file) ?
(Assignee)

Comment 15

16 years ago
I started a project at Mozdev for this.  Hopefully some individual will come out 
to help.  I think we can create a pretty flexible system that would meet the 
needs of parents/schools etc, yet provide an unpresidented amount of choice as 
far as what to block, and how to block it.

http://securita.mozdev.org/
HJ: there is no such feature that I know of.

Comment 17

16 years ago
http://www.junkbusters.com/ijb.html

You could use Junk Buster.  
The only difference would be the content you were trying to block, and
junkbuster allows you to specify your own wordlists.  

There are plenty of alternative approaches, a more efficient system would be to
whitelist a whole bunch of approved sites.  
Another approach is to log all visited sites (and checking the logs) and show a
little trust.  


I urge you to fundamentally reevaluate what you are trying to achieve and why. 
Your motives seem sincere but please consider the implications of what you are
trying to do.  There are better ways to educate inform and guide (not just
young) people.  
http://www.peacefire.org/
(Assignee)

Comment 18

15 years ago
I formed the Securita project a while back to take on this bug.  I'm now coding
some myself in spare cycles I have (as limited as they are).

No timetable yet.
Status: NEW → ASSIGNED
How much overhead will this add to the DOM? Is there a risk that a long block
list combined with a textually heavy page could cause some slowdowns?

Comment 20

14 years ago
hopefully whitelists/blacklist support will be included
(Assignee)

Comment 21

14 years ago
Anything that involves a task will create some sort of a slowdown.  Obviously we
will keep it to a minimum.

At least as I see it now, there's no plan to integrate such a feature into
Mozilla.  It will be an extension, and a separate effort.

As far as whitelist/blacklist... most likely in the future.
Product: Browser → Seamonkey
(Assignee)

Comment 22

14 years ago
Any development on this should take place at:
http://securita.mozdev.org

Closing as WONTFIX since it will be done at mozdev.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.