crash in _JNIEnv::CallStaticObjectMethod(_jclass*, _jmethodID*, ...) | anp_system_loadJavaClass(_NPP*, char const*)

RESOLVED FIXED in Firefox 28

Status

()

--
critical
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: kbrosnan, Assigned: snorp)

Tracking

(4 keywords)

Trunk
Firefox 29
All
Android
crash, regression, reproducible, topcrash-android-armv7
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28+ fixed, firefox29 fixed, fennec28+)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-ac3f0152-5a3d-4bdf-887c-76c242131208.
=============================================================

Seems to be Flash related. Will investigate URLs later.
(Reporter)

Updated

5 years ago
tracking-fennec: --- → ?
status-firefox27: --- → unaffected
status-firefox28: --- → affected
status-firefox29: --- → affected
tracking-firefox28: --- → ?
I can reproduce this easily just by going to http://people.mozilla.org/~jwillcox/flash/flash_test.html
Assignee: nobody → snorp
https://crash-stats.mozilla.com/report/index/dfc696a3-8528-48b2-bc9d-0bead2131205 if needed too has a comment/email
Keywords: regression, reproducible
(Reporter)

Comment 3

5 years ago
STR:
* Go to YouTube
* Request desktop site
* Click on a video
* Activate Flash
* Press the full screen button
+ Crash

* Does not affect HTML <video>
Created attachment 8345970 [details] [diff] [review]
Mark GeckoAppShell.loadPluginClass() as used from JNI

Looks like this got broken when ProGuard was enabled.
Attachment #8345970 - Flags: review?(chriskitching)
Attachment #8345970 - Flags: review?(chriskitching) → review?(blassey.bugs)
Comment on attachment 8345970 [details] [diff] [review]
Mark GeckoAppShell.loadPluginClass() as used from JNI

Review of attachment 8345970 [details] [diff] [review]:
-----------------------------------------------------------------

r=blassey if you didn't intend to remove jSetSelectedLocale and drop that part of the patch

::: widget/android/GeneratedJNIWrappers.h
@@ -162,5 @@
>      static jmethodID jScheduleRestart;
>      static jmethodID jSendMessageWrapper;
>      static jmethodID jSetFullScreen;
>      static jmethodID jSetKeepScreenOn;
> -    static jmethodID jSetSelectedLocale;

why?
Attachment #8345970 - Flags: review?(blassey.bugs) → review+
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #5)
> Comment on attachment 8345970 [details] [diff] [review]
> Mark GeckoAppShell.loadPluginClass() as used from JNI
> 
> Review of attachment 8345970 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=blassey if you didn't intend to remove jSetSelectedLocale and drop that
> part of the patch
> 
> ::: widget/android/GeneratedJNIWrappers.h
> @@ -162,5 @@
> >      static jmethodID jScheduleRestart;
> >      static jmethodID jSendMessageWrapper;
> >      static jmethodID jSetFullScreen;
> >      static jmethodID jSetKeepScreenOn;
> > -    static jmethodID jSetSelectedLocale;
> 
> why?

*shrug*

That file is automatically generated. I didn't change that line. I'd say someone modified it by hand and forgot to remove that?
The jSetSelectedLocale stuff was removed in https://hg.mozilla.org/mozilla-central/rev/cd918aef9e64 but the part in the header remained.
Comment on attachment 8345970 [details] [diff] [review]
Mark GeckoAppShell.loadPluginClass() as used from JNI

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 709230 
User impact if declined: Flash goes boom
Testing completed (on m-c, etc.): None yet
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8345970 - Flags: approval-mozilla-aurora?
Depends on: 709230
https://hg.mozilla.org/mozilla-central/rev/9e6bdc10cf33
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
tracking-fennec: ? → 28+
tracking-firefox28: ? → +
Attachment #8345970 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/3ec4c87136ca
status-firefox28: affected → fixed
status-firefox29: affected → fixed
You need to log in before you can comment on or make changes to this bug.