[B2G][Browser] The user can submit a blank Sign up for our monthly newsletter form

RESOLVED DUPLICATE of bug 943869

Status

RESOLVED DUPLICATE of bug 943869
5 years ago
5 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: dogfood1.2)

Attachments

(2 attachments)

Description:
If the user closes the "Sign up for our monthly newsletter window", reopens it and then taps on "Sign me up", they will submit a blank form. If they reopen the window, they will then see an error message stating "Please enter a valid email address. You must agree to the privacy policy".

Repro Steps:
1) Updated Buri to Build ID: 20131209004003
2) Tap on the "Browser" icon.
3) Tap on the URL http://mozilla.org/firefoxos in "Bookmarks".
4) Tap on "Sign me up".
5) Tap on "Close X" when the window appears.
6) Tap on "Sign me up" again.
7) On the "Sign me up for our monthly newsletter" window, tap on "Sign me up" without filling out the form.
8) The window will close like the form was submitted. Tap on "Sign me up" again to reopen the window.


Actual:
The form will submit if the user opens the "Sign me up for our monthly newsletter" window, closes the window, reopens the window and taps on "Sign me up" without filling out the form. Also, the error message won't appear until the user reopens the window again.

Expected:
The form does not submit and the user is prompted an error message when the try to submit a blank form.

Environmental Variables
Device: Buri v 1.2.0 COM RIL
Build ID: 20131209004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/f684b8f159a3
Gaia: f615ae7acb6731d191b3094e10e314bc28359bbb
Platform Version: 26.0
RIL Version: 01.02.00.019.102 

Notes:
Repro frequency: 100%
See attached: logcat, video
This issue reproduces on Leo v 1.1.0 COM RIL 

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20131024041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/e4cb5a852e3d
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Platform Version: 18.1
RIL Version: 01.01.00.019.264 

The user can submit the "Sign me up for our monthly newsletter" without filling out the form.
Created attachment 8344773 [details]
Submittingblankformlog.txt
Created attachment 8344777 [details]
Blankformsubmit.mp4
Component: Gaia::Browser → General
Product: Firefox OS → www.mozilla.org
I can't reproduce on my laptop.

Raymond - could you please check on an Fx OS device?
Flags: needinfo?(mozbugs.retornam)
QA Contact: mozbugs.retornam
This is a valid bug
Flags: needinfo?(mozbugs.retornam)
QA Contact: mozbugs.retornam
The validation on this form is standard html5 "required" attributes. The validation works properly on desktop Fx and Fx for Android. I don't think there's anything we can do to this form to make it work properly on FxOS as it seems to be a bug in the handling of html5 form validation in the FxOS Browser.
Component: General → Gaia::Browser
Product: www.mozilla.org → Firefox OS
Component: Gaia::Browser → DOM
Product: Firefox OS → Core
if it works on FxAndroid but doesn't work FxOS, then my guess is that this is a DOM bug
Is the bug reproducible in a desktop build from the same gecko revision?  I tried Firefox 26 desktop and the bug does _not_ show up there, which is very curious: if this were a DOM bug I'd expect it to affect all the browsers built on the same Gecko the same way.  (As in, comment 7 sounds backwards to me.)
(In reply to Boris Zbarsky [:bz] from comment #8)
> Is the bug reproducible in a desktop build from the same gecko revision?  I
> tried Firefox 26 desktop and the bug does _not_ show up there, which is very
> curious: if this were a DOM bug I'd expect it to affect all the browsers
> built on the same Gecko the same way.  (As in, comment 7 sounds backwards to
> me.)

If it isn't DOM-based, then what other components could be causing this? The above comments seem to imply that this only happens on FxOS, not desktop & fx android. Could it be a Gaia bug?
> If it isn't DOM-based, then what other components could be causing this?

I have no idea.  The DOM code is presumably the same on all branches and should be preventing the submission, but UI code could probably do something weird to override this and do the submit anyway if it tried hard enough....

The hypothesis that no one has messed with the DOM code on the device in question should be checked, of course.
ktucker - Can you check what happens on FxAndroid with the bug's STR?
Flags: needinfo?(ktucker)
I could not reproduce this on my android phone with the Firefox browser using the steps above. The form will not submit until the user fills out the form. The email field and the Privacy Policy check box will be highlighted red to indicate to the user that they must complete these areas to submit the form.
Flags: needinfo?(ktucker)
Component: DOM → Gaia::Browser
Product: Core → Firefox OS
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 943869
You need to log in before you can comment on or make changes to this bug.