Different Screen Resolution Simulator Support

RESOLVED FIXED

Status

Firefox OS
Simulator
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Axel Kratel, Assigned: janx)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [status:onhold][SUMO-b2g])

(Reporter)

Description

4 years ago
As a developer, I would like to be able to simulate the layout for multiple device screen resolutions so that I can optimize my code to make sure my app looks and runs properly within the desired screen resolutions. 

Acceptance criteria:
* User can select specific screen types to make the simulator show the app running in the desired screen size. 
* Available screen resolutions should be the following:
- HVGA
- WVGA
- FWVGA
- 720p
- qHD (lowest priority)

Updated

4 years ago
QA Contact: paul

Updated

4 years ago
Assignee: nobody → paul
QA Contact: paul

Updated

4 years ago
Component: Developer Tools: User Stories → Simulator
Product: Firefox → Firefox OS
Version: Trunk → unspecified

Comment 1

4 years ago
This is now important as we have the tablet device being tested by the TCP community (https://wiki.mozilla.org/FirefoxOS/TCP)

The 1st tablet device is the Foxconn InFocus New Tab F1 with  resolution of 1280x800 - Landscape can be assumed to be the most common orientation.

I think we should have resolution options for all the devices out there. Since being raised the Flame has launched and the ZTE Open C, plus no doubt others. Options for these devices might make more sense than actual resolutions.

We need to encourage good responsive design for all apps and that means testing on a range of resolutions without devices.

Comment 2

4 years ago
The MDN docs [1] state --screen option exists for b2g-bin.exe but it doesn't work on windows, is not listed in the usage (--help) and I cannot find it in the source (nsAppRunner.cpp)

1: https://developer.mozilla.org/en-US/Firefox_OS/Using_the_B2G_desktop_client?redirectlocale=en-US&redirectslug=Firefox_OS%2FUsing_the_B2G_desktop_client#option-screen

Comment 3

4 years ago
Having debugged it seems the option does work (b2g/chrome/content/screen.js) but the MDN docs explained the option in the OS X specific format, not the normalised form that works on all platforms (and I was on Windows). I've corrected the MDN docs.

This option is only available from the command line, not in the simulator itself. This should be fixed.

Comment 4

4 years ago
The command line to invoke the simulator runs the B2G extension with the simulator profile and the -screen option to specify the size. 

For example on Windows this script gives a flatfish Tablet size screen

set fxProfile=41y2qbg1.default        (or whatever the correct profile is)
set simRoot=C:\Users\%username%\AppData\Roaming\Mozilla\Firefox\Profiles\%fxProfile%\extensions\fxos_2_0_simulator@mozilla.org
set simBin=%simRoot%\b2g\b2g-bin.exe
%simBin% -dbgport 6000 -screen 1200x800 -profile %simRoot%\profile  

For example on OS X
/path/to/Firefox/profile/extensions/fxos_1_3_simulator@mozilla.org/resources/fxos_1_3_simulator/data/mac64/B2G.app/Contents/MacOS/b2g-bin -dbgport 6000 -profile /path/to/Firefox/profile/extensions/fxos_1_3_simulator@mozilla.org/profile -screen <width>x<height>[@<dpi>] 

See https://developer.mozilla.org/en-US/Firefox_OS/Using_the_B2G_desktop_client#option-screen for the screen options

You might also want to add -no-remote so it works with Firefox already running

However there appear to be some layout bugs to be resolved.

Updated

4 years ago
Depends on: 1020668
(Reporter)

Updated

4 years ago
Whiteboard: [User Story] → [status:onhold]

Updated

4 years ago
Blocks: 1020668
No longer depends on: 1020668
As mentioned in bug 1020668, it is important to note that modifying the simulator screen size won't be enough to get the whole Table/TV experience. You need a specific gaia profile.

From a technical standpoint, I think there might be an issue where b2g desktop/simulator doesn't open a window with the same size that would be use on a real hardware.
A first iteration to ease the support of products other than Phones would be to somehow detect the expected size out of the custom gaia profile being given. Otherwise I don't think there is any specific in b2g runtime.

Updated

4 years ago
Duplicate of this bug: 1053014

Updated

3 years ago
Assignee: paul → janx

Comment 7

3 years ago
For tracking purposes -
A user/developer inquired about this issue in the SUMO forums:
https://support.mozilla.org/en-US/questions/1027978

Thanks,
- Ralph
Whiteboard: [status:onhold] → [status:onhold][SUMO-b2g]
(Assignee)

Updated

3 years ago
Depends on: 1090949
Duplicate of this bug: 930370
Duplicate of this bug: 932828
Duplicate of this bug: 1090154
(Assignee)

Comment 11

2 years ago
This is now possible in WebIDE using the Simulator configuration screen ("setting" icon next to a simulator name).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.