Change pagination serializer settings

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: mat, Unassigned)

Tracking

x86_64
Linux
Points:
---

Details

(Reporter)

Description

5 years ago
When we switched to DRF, we kept compatibility with how tastypie does pagination by setting the default pagination serialization class to one built for this purpose. However, it needs something in the view to properly work. So I built the necessary code in MarketplaceView base class.

This cause problems when we forget to inherit from MarketplaceView, so this kinda sucks. This caused bug 948084 and bug 945709. 

We should investigate whether there is an alternative solution, but this seems like the best plan: Let's have 2 pagination serializers:

- A basic one
- Another one with the tastypie compatibility (offset-style pagination)

Instead of defaulting to the second one, we should default to the basic one in the settings and only use the other in MarketplaceView and its children, by setting pagination_serializer_class.
Blocks: 940398

Updated

5 years ago
Priority: -- → P3

Updated

4 years ago
Component: API → Code Quality
(Reporter)

Updated

3 years ago
Duplicate of this bug: 964921
(Reporter)

Comment 2

3 years ago
Never going to happen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.