Bump Robocop to 4.3.1

RESOLVED FIXED in Firefox 29

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

Trunk
Firefox 29
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
It fails on KitKat otherwise.

http://stackoverflow.com/questions/20143119/classcastexception-in-junit-tests-with-android-kitkat

That I'm the first to report this is *terrifying*.
(Assignee)

Comment 1

5 years ago
Created attachment 8344940 [details] [diff] [review]
Upgrade Robotium to 4.3.1.
(Assignee)

Updated

5 years ago
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Attachment #8344940 - Flags: review?(mark.finkle)
Comment on attachment 8344940 [details] [diff] [review]
Upgrade Robotium to 4.3.1.

Looks like we also update the JAR name in the README here:
build/mobile/robocop/README
Attachment #8344940 - Flags: review?(mark.finkle) → review+

Updated

5 years ago
Blocks: 935129
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/3103352e20de

gbrown, does this need to be uplifted?
Target Milestone: --- → Firefox 29
(In reply to Richard Newman [:rnewman] from comment #3)
> gbrown, does this need to be uplifted?

In the past, we have not bothered. I would let it ride the trains.
https://hg.mozilla.org/mozilla-central/rev/3103352e20de
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 935129
You need to log in before you can comment on or make changes to this bug.