Closed Bug 948195 Opened 6 years ago Closed 6 years ago

Marketplace is incorrectly listed in the Games bubble in the Search screen

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: krupa.mozbugs, Assigned: amirn)

References

Details

(Whiteboard: [systemsfe])

Attachments

(4 files)

OS version: 1.3.0.0-prerelease
Build identifier: 20131208063021
Device used in test: Fugu

steps to reproduce:
1. Start the phone such that the Search screen loads with the apps organized by functionality bubbles.
2. Notice the Games bubble

observed behavior:
Marketplace is listed under Games when it should be listed under settings

NOTE: I checked on my inari (build:20131118040206) where marketplace is listed under settings. See
Blocks: 948661
blocking-b2g: --- → 1.3?
Blocks: 1.3-e.me
No longer blocks: 948661
Assignee: nobody → yosef
Hi Krupa

I don't agree that the Marketplace doesn't belong to the Games category. On every ecosystem, users are directed to the marketplace to find games to play. The marketplace has games - many of the most popular apps are games, and Games is the first category on the list (and probably one of the most popular of them). Therefore, I don't think any change is necessary.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(krupa.mozbugs)
Resolution: --- → INVALID
(In reply to Yosef Waysman from comment #2)
> Hi Krupa
> 
> I don't agree that the Marketplace doesn't belong to the Games category. On
> every ecosystem, users are directed to the marketplace to find games to
> play. The marketplace has games - many of the most popular apps are games,
> and Games is the first category on the list (and probably one of the most
> popular of them). Therefore, I don't think any change is necessary.

I disagree with this. Marketplace is a not a game, so that doesn't make sense to include it as part of a games collection. It's a place to find apps, which can include gaming apps.

Bill - Can you weigh in on what you want to do here?
Status: RESOLVED → REOPENED
Flags: needinfo?(wmaggs)
Resolution: INVALID → ---
Yosef, 

I agree with Jason and Krupa and here's why. Lots of folks on like Ran, Wil, Krupa, and others have done a lot of work so that Marketplace apps and the destination itself are discoverable for that part of a users intention to find permanent apps from Home Screen search, and I think we have a good, understandable result for exposing the cue to go the Marketplace that serves the user well. I don't think putting the Marketplace icon in any of the instant apps Smart Folders is consistent with that approach. So please, yes, remove Marketplace icon from the bubbles and the folders. 

I think a lot of us really want to merge the ideas of instant or cloud apps delivered by e.me and Marketplace apps; for a variety of reasons we are not there yet.  So it is confusing to have the Marketplace icon show up with the cloud apps because it isn't one itself, and takes people to a download experience rather than an instant apps experience. You're right that there are games in the Marketplace, but for category searches like that Ran and you have been nice enough to surface the  category labels on the Marketplace icon (see attachment for Download reference if you search for reference). BTW in the current 

BTW, on my 1.3 Keon (build id 20131210025136) the Smart Folders do not show up at all.
Flags: needinfo?(wmaggs)
Flags: needinfo?(yosef)
Flags: needinfo?(ran)
I agree with everything Jason and Bill have added in the above comments.
Flags: needinfo?(krupa.mozbugs)
Ok. If you think it should be removed we won't insist.
Amir - please remove the Marketplace from the Games smart collection.
Assignee: yosef → amirn
Flags: needinfo?(yosef)
OK, so we need to decide on 3 apps that will show up in the initial icon and create new assets.
(ref. https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/collections/games)

The initial icon will be updated on the first launch of the collection (assuming the device is online).
Until then, the initial icon will be displayed.
Flags: needinfo?(ran)
Ok. Let's use the icons of the following apps for the initial icon:
1. Free Games
2. Gem Adventure
3. Galacticans 2

Fade - please make sure the icon is created and passed to Amir.
Assignee: amirn → fade
blocking-b2g: 1.3? → 1.3+
Whiteboard: [systemsfe]
PM retriaged this and we agree with the blocking status.
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
(Amir, we can create this icon on our own)
Assignee: fade → amirn
Attached file Github Pull Request
Attachment #8362474 - Flags: review?(ran)
Comment on attachment 8362474 [details] [review]
Github Pull Request

Great
Attachment #8362474 - Flags: review?(ran) → review+
landed in master: https://github.com/mozilla-b2g/gaia/commit/085a578
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Please when committing new or modified PNG files make sure they have been properly recompressed with the script provided under tools/png_recompress.sh. Note that to run the script you will need the optipng and advpng tools which are usually provided by the optipng and advancecomp packages on most Linux distributions.

Here's an example of how to run it and its output using the images committed in this bug:

$ ./tools/png_recompress.sh -v apps/homescreen/collections/games/icon.png \
                               apps/homescreen/collections/games/icon@1.5x.png \
                               apps/homescreen/collections/games/icon@2x.png

apps/homescreen/collections/games/icon.png 4875 3814 0.782
apps/homescreen/collections/games/icon@1.5x.png 7840 6640 0.846
apps/homescreen/collections/games/icon@2x.png 11960 10596 0.885

Number of files processed: 3
Total size of the files prior to recompression: 24675
Total size of the files after recompression: 21050
Compression ratio: 0.853
followup - compressed PNG:
landed in master: https://github.com/mozilla-b2g/gaia/commit/261e06dc07470d50a47d37e0104af7c7099cc803
landed in v1.3: https://github.com/mozilla-b2g/gaia/commit/99aca97f351fcd3b07dd0b47d27627899c3bcc42

Gabriel - I was not aware this is required, sorry.
Perhaps adding a commit hook when adding PNG's is a good way to alert developers in the future.

Thanks.
(In reply to Amir Nissim (Everything.me) from comment #17)
> Gabriel - I was not aware this is required, sorry.

It's not required, we're just trying to enforce it since we landed bug 959659.

> Perhaps adding a commit hook when adding PNG's is a good way to alert
> developers in the future.

I'm trying to implement something along the lines, I just didn't have enough time yet. Thanks for having updated the images!
You need to log in before you can comment on or make changes to this bug.