Closed Bug 948231 Opened 7 years ago Closed 7 years ago

[Australis] History Button's Customize item breaks button until restart

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tawn, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131204004002

Steps to reproduce:

1. Click PanelUI (hamburger) button
2. Click Customize
3. Drag History button to Navigation Toolbar
4. Exit Customize
5. Click History button
6. Click 'Customize Nightly' (in history item list)
7. Customize opens; Exit Customize
8. Click History Button



Actual results:

History button no longer responds to clicks at step 7. (Button works again after a restart) 


Expected results:

History button should open its list of history items.
Whiteboard: [Australis:P3]
I haven't been able to reproduce this. Are there any errors in the browser console, and can you reproduce on a clean profile?
Component: Untriaged → Toolbars and Customization
Flags: needinfo?(stayopenmenu)
(In reply to :Gijs Kruitbosch from comment #1)
no consistent errors appear in browser console (sporadic ones look irrelevant)
yes, I can repro on clean profile (and still occurs on updated Nightly 2014-1-16)

Correction to 'Actual Results': /at step 7/ should have been /after step 7/

Couple things I just noticed:
1. Prior to clicking the History Button in step 8, it still has that activated appearance (shading and border around it - like it looks when its panel is open)
2. When the button starts working again after Fx is restarted, 'Customize Nightly' and 'Restore all tabs' are no longer in the panel opened by clicking the button
3. Right-click on the History Button works fine; only left click is affected
Flags: needinfo?(stayopenmenu)
Can't reproduce on nightly 29.0a1 (2014-01-28), win 7 x64.

Please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

Or on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
(In reply to Paul Silaghi, QA [:pauly] from comment #3)
As I mentioned in comment #2, it was occurring for me in a clean (aka new, empty) profile on the 2014-1-16 build. However, I can no longer reproduce on the 2014-01-30 nightly build. So assuming some change between those 2 builds fixed the issue.
(In reply to custom.firefox.lady from comment #4)
> However, I can no longer reproduce on
> the 2014-01-30 nightly build. So assuming some change between those 2 builds
> fixed the issue.
That's what I was hoping.
You need to log in before you can comment on or make changes to this bug.