®, ©, and ™ all show up as ? within a diamond

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: ediestone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

5 years ago
What did you do?
================
1. entered characters from keyboard as usual- new problem (previously characters displayed OK)
2. copied and pasted characters from little window named Characters, Letterlike Symbols - same problem
3. uploaded page via Cyberduck2 as usual, refreshed new version each time - in Chrome, SeaMonkey, FireFox

What happened?
==============
Same problem - lots of question marks within diamonds

See my page http://bouldercouplescounseling.com/ to view the problem - near the bottom of page describing trainings, all of which need © or ® or ™ 

What should have happened?
==========================
view the characters correctly

Is there anything else we should know?
======================================
I am using Mac OS 10.6.8
 Model Name:	MacBook
  Model Identifier:	MacBook3,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.2 GHz

I am a therapist, not a programmer, so I hope someone can help please.
Component: General → General
Product: Mozilla Developer Network → Firefox

Comment 1

5 years ago
Reproducible on the 12/22/13 Nightly:
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

This is also reproducible on other browsers on my machine (e.g. Chrome) so it might also pe a website issue.
Status: UNCONFIRMED → NEW
Component: General → Layout: Text
Ever confirmed: true
Product: Firefox → Core
Ioana, if there's a U+FFFD (�) involved, that tends to be the result of an encoding issue and belongs in Core::i18n.

In this case, the issue is that the HTTP response has a

  Content-Type: text/html; charset=UTF-8

header, which overrides the

  <meta content="text/html; charset=windows-1252"
    http-equiv="content-type">

declaration in the page.

Edie: the easiest (and best) solution on your side is probably to encode the page as UTF-8; feel free to let me know if you need help with that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: Layout: Text → Internationalization
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.