Closed Bug 948307 Opened 7 years ago Closed 7 years ago

[DSDS] SIM manager is loaded about half second later than other items in Settings when first launch the list.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, firefox29 fixed, b2g-v1.3 verified)

VERIFIED FIXED
blocking-b2g 1.3+
Tracking Status
firefox29 --- fixed
b2g-v1.3 --- verified

People

(Reporter: echu, Assigned: eragonj)

References

Details

(Whiteboard: [dsds_US_test])

Attachments

(5 files, 2 obsolete files)

When first time launch Settings, it takes about half second to display SIM manager in the list. Hope system can behave consistently for at least items on the page shown right after launching Settings.

* Build Number                
Fugu
Gaia      fbb6ce88ce8b7bd4d2efdb7a4a9f5a3c145f3eab
Gecko     a0bb585098cc89c454fac0297b5ef748d5cab82c
BuildID   20131210063021
Version   28.0a1

* Reproduce Steps
1. Remove Settings from task manager
2. Launch Settings.
3. Check SIM manager after item list is shown.

* Expected Result
SIM manager should be shown with other items at the same time.

* Actual Result
After other items are listed(items on the page without scrolling down the list) for about half second, SIM manager will be seen.

* Occurrence rate
100%
Whiteboard: [dsds_US_test]
Attached video VID_0001.3gp
Displaying SIM manager in the first place regresses the settings app launch time. (https://bugzilla.mozilla.org/show_bug.cgi?id=932731#c32) There is a trade off here. Neo, could you provide some inputs about the issue? We would like to determine if this impacts the UX.
Flags: needinfo?(nhsieh)
loop in DSDS UX owner Carrie.
(In reply to Arthur Chen [:arthurcc] from comment #2)
> Displaying SIM manager in the first place regresses the settings app launch
> time. (https://bugzilla.mozilla.org/show_bug.cgi?id=932731#c32) There is a
> trade off here. Neo, could you provide some inputs about the issue? We would
> like to determine if this impacts the UX.

Hi Carrie, could you help to comment on Arthur's question?
Flags: needinfo?(nhsieh) → needinfo?(cawang)
Hi both, 

I've checked the interaction on devices with Enpei and I really expect that SIM manager should be shown with other items at the same time, otherwise, it will be really weird. :(
Thanks!
Flags: needinfo?(cawang)
Neo proposed an idea of moving the SIM manager item to the after so it won't be displayed when launching settings app. Not sure if it feasible?
Flags: needinfo?(cawang)
Hi all,

Just discussed with Vicamo, the thing gecko could do is delaying the init to MobileConnectionArray::IndexedGetter.
So in MobileConnectionArray constructor we only set the array length but don't init the element. This could help but need to have WIP first to know how much it actually improves.
(In reply to Hsin-Yi Tsai  [:hsinyi] from comment #7)
> Hi all,
> 
> Just discussed with Vicamo, the thing gecko could do is delaying the init to
> MobileConnectionArray::IndexedGetter.
> So in MobileConnectionArray constructor we only set the array length but
> don't init the element. This could help but need to have WIP first to know
> how much it actually improves.

Thanks Hsin-Yi,

we can make a test to see whether that WIP works well with Gaia as what we thought. 

Thanks :P
EJ, 

Could you try the attached WIP patch? It's a quick patch, not sure if everything works as expected.

Thanks.
(In reply to Jessica Jong [:jjong] [:jessica] from comment #9)
> Created attachment 8346515 [details] [diff] [review]
> [WIP] delay mobileconnections initialization (git format)
> 
> EJ, 
> 
> Could you try the attached WIP patch? It's a quick patch, not sure if
> everything works as expected.
> 
> Thanks.

okkk ! I'll give a try and reply back soon. 

Thanks Jessica.
(In reply to Jessica Jong [:jjong] [:jessica] from comment #9)
> Created attachment 8346515 [details] [diff] [review]
> [WIP] delay mobileconnections initialization (git format)
> 
> EJ, 
> 
> Could you try the attached WIP patch? It's a quick patch, not sure if
> everything works as expected.
> 
> Thanks.

Hi Jessica, I just updated the gaia part and tested on Fugu. 

They all work as what I expect and I think you can apply my patch on Gaia and give it a try on your device.

I will try to run b2gperf tool later because my build environment is broken due to some unknown error and I am still fixing it.
(In reply to Arthur Chen [:arthurcc] (PTO 12/25 ~ 1/5) from comment #6)
> Neo proposed an idea of moving the SIM manager item to the after so it won't
> be displayed when launching settings app. Not sure if it feasible?

Since this is for dual SIM devices, SIM manager should be promoted as high priority. Hence, I don't suggest to move the item in this case. Thanks!
Flags: needinfo?(cawang)
Hi all, I tested on Fugu with two different situations below :

1. With new Gecko & Gaia patch : 

2013-12-23 18:37:46,413 B2GPerfRunner INFO    | Results for Settings, cold_load_time: median:881, mean:1174, std: 508, max:2215, min:813, all:1964,881,1016,2062,1988,1966,885,1944,862,907,2021,860,830,881,1943,2215,821,888,873,840,859,854,863,867,813,902,882,860,841,851

2. Without Gecko & Gaia patch (master) :

2013-12-23 18:51:59,518 B2GPerfRunner INFO    | Results for Settings, cold_load_time: median:1572, mean:1401, std: 234, max:1648, min:1061, all:1376,1587,1594,1587,1088,1091,1607,1071,1610,1108,1579,1645,1575,1591,1648,1561,1110,1594,1591,1637,1570,1624,1609,1061,1143,1133,1141,1163,1177,1163

Based on the median value we got from b2gperf (b2gperf --delay=10 Settings), it seems that if we have these two patches on Gaia and Gecko will make simcard manager show up quickly and users will not recognize the latency time. 

If there are no side effects on Gecko and Gaia, I think this approach is good to go. 

Thanks all :)
ni? Carrie, Arthur and Hsin-Yi for more discussion based on the experiment I tried above.
Flags: needinfo?(htsai)
Flags: needinfo?(cawang)
Flags: needinfo?(arthur.chen)
Thanks Jessica's WIP. I think the idea is fine to go. A separate bug 953005 has been filed for the gecko enhancement.
Flags: needinfo?(htsai)
EJ, did you test the patches with unagi? I was wondering do users notice the disappearing of the menu item with single sim devices as we show the menu item by default.
Flags: needinfo?(arthur.chen) → needinfo?(ejchen)
My Inari works well without the patch !
Flags: needinfo?(ejchen)
(In reply to EJ Chen [:eragonj](PTO: 12/25 ~ 1/5) from comment #18)
> My Inari works well without the patch !

I mean Gecko patch :P
I thought we are going to land both the gaia and gecko patches? If so we need to test the patches with a single sim device.
(In reply to Arthur Chen [:arthurcc] (PTO 12/25 ~ 1/5) from comment #20)
> I thought we are going to land both the gaia and gecko patches? If so we
> need to test the patches with a single sim device.

Yeah I know, Arthur. 

I am trying to build a new gecko on my desktop now. Thanks :)
After testing on Inari, it works well and there is no blinking problem when Gecko & Gaia patches got applied. 

Here comes the performance test : 

1. With Gecko & Gaia patch : 

2013-12-24 16:45:46,347 B2GPerfRunner INFO    | Results for Settings, cold_load_time: median:747, mean:760, std: 46, max:947, min:721, all:947,738,740,753,764,730,744,737,892,747,743,747,739,750,721,786,802,738,763,741,732,755,736,747,749,746,799,748,740,750

2. Compared with the data from datazilla (http://goo.gl/s1ECiB) :  

Application: settings 
Gaia Revision: 9ed515d0ede35198
Date:2013-12-24 14:08:52
Avg:1209.23 Min:1159 Max:1321 Std:53.48

I think this approach works well as what we have expected no matter on single sim device or dual sim. Hope this information helps :)
By the way, on engineering side, I think Gecko needs to apply its patch first so that we can make sure Gaia change will not influence user experiences (blinking panel).
Hi, I've checked the new patch with EJ. I think it looks fine now, although the latency of getting into Settings APP is quite obvious, but at least SIM manager shows up at the same time with other items.
Thanks!
Flags: needinfo?(cawang)
(In reply to EJ Chen [:eragonj](PTO: 12/25 ~ 1/5) from comment #23)
> By the way, on engineering side, I think Gecko needs to apply its patch
> first so that we can make sure Gaia change will not influence user
> experiences (blinking panel).

Agree. Bug dependency has been set.
Depends on: 953005
Attached file patch (obsolete) —
Attached file patch (obsolete) —
Attached file patch on master
Added a new patch based on master code (original patch is outdated.) and will ask for review after using new Gecko build.
Assignee: nobody → ejchen
Attachment #8361450 - Attachment is obsolete: true
Attachment #8361451 - Attachment is obsolete: true
Comment on attachment 8361453 [details] [review]
patch on master

Hi Arthur, when you got the newest build with Gecko patch, please help me review this small patch. Thanks ! :)
Attachment #8361453 - Flags: review?(arthur.chen)
Comment on attachment 8361453 [details] [review]
patch on master

r=me. Please merge with travis green, thanks!
Attachment #8361453 - Flags: review?(arthur.chen) → review+
I am nominating this as 1.3+ because this issue directly affects user experience.
blocking-b2g: --- → 1.3?
Beatriz,

Can you please comment if this would block IOT. The flash seen lasts for 1/2 a second and wondering if we can live with it.
Flags: needinfo?(brg)
Thanks all, just merged this change on gaia/master : dd16763b6301f5df0e3531e3f17aad8f46ff10ad

:)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Preeti Raghunath(:Preeti) from comment #32)
> Beatriz,
> 
> Can you please comment if this would block IOT. The flash seen lasts for 1/2
> a second and wondering if we can live with it.
We will manage it. Thanks for asking.
Flags: needinfo?(brg)
blocking-b2g: 1.3? → 1.3+
Uplifted dd16763b6301f5df0e3531e3f17aad8f46ff10ad to:
v1.3: 8493b838144ae9ff7bef9cac1f678aa1e5ace0ff
(In reply to John Ford [:jhford] -- please use 'needinfo?' instead of a CC from comment #35)
> Uplifted dd16763b6301f5df0e3531e3f17aad8f46ff10ad to:
> v1.3: 8493b838144ae9ff7bef9cac1f678aa1e5ace0ff

Thanks John !
Verified on 
Fugu
Gaia      6fbeac2415f07f10de181f0877ddf67ee299b885
Gecko     086e69971516130ad297c7f950dfb42a995217e9
BuildID   20140123115514
Version   28.0a2

Now SIM Manager will show along with Call/Messaging/Cellular & Data.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.