Firefox ugly tooltips on Ubuntu (much bigger than the text inside)

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: florin arjocu, Unassigned)

Tracking

25 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131211])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8345245 [details]
Tooltip not proportional with content on Ubuntu

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131115105349

Steps to reproduce:

I am not sure if this was reported before, but I just want to say that tooltips are not proportional with the text that they contain. It is a lot larger and a black rectangle is not so beautiful on our screen :)


Actual results:

Hover close buttons, etc.


Expected results:

Have a tooltip proportional with it's contents.

Comment 1

5 years ago
Thanks for the report.

Can you reproduce it with a build from Mozilla (not Ubuntu)?  Please download it from https://www.mozilla.org/ and run with -no-remote or with a new profile.

Are you using multiple monitors, or a hidpi monitor?
Flags: needinfo?(florin.arjocu)
Whiteboard: [bugday-20131211]

Updated

5 years ago
Summary: Firefox ugly tooltips on Ubuntu → Firefox ugly tooltips on Ubuntu (much bigger than the text inside)
(Reporter)

Comment 2

5 years ago
Am I doing something wrong? I extracted the archive and tried to run it but I get some error. This is what I get:

~/Downloads/firefox/firefox -no-remote
XPCOMGlueLoad error for file /home/florin/Downloads/firefox/libxul.so:
libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
Flags: needinfo?(florin.arjocu)
(Reporter)

Comment 3

5 years ago
I use a normal laptop with no external monitor, integrated graphics from Intel.

Comment 4

5 years ago
(In reply to florin arjocu from comment #2)
> ~/Downloads/firefox/firefox -no-remote
> XPCOMGlueLoad error for file /home/florin/Downloads/firefox/libxul.so:
> libdbus-glib-1.so.2: cannot open shared object file: No such file or
> directory
> Couldn't load XPCOM.

Sorry, that's a 32-bit version.  You can get a 64-bit one from https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/25.0.1/linux-x86_64/ or a 64-bit Nightly build from http://nightly.mozilla.org/
(Reporter)

Comment 5

5 years ago
Tried to run the version 25.0.1 from the link you provided and it only ran to check plugins and then it closed.
florin@ToshibaSatellite-C650L:~/Downloads/firefox$ ~/Downloads/firefox/firefox -no-remote
(process:29576): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
(firefox:29576): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised
(firefox:29576): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised
(firefox:29576): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised
(firefox:29576): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised



Earlier today I have upgraded to version 26. So after manually trying 25.0.1 (see above), I started v26, the one installed from Software Center. Now it seems to be working better, the tooltips for Close are exactly the size of "Close". I do not know how what happened or if it something to interfere with the plugins. I am attaching a screenshot.
(Reporter)

Comment 6

5 years ago
Created attachment 8346062 [details]
Firefox 26 on the last run does not seem to have this problem

Comment 7

5 years ago
(In reply to florin arjocu from comment #6)
> Created attachment 8346062 [details]
> Firefox 26 on the last run does not seem to have this problem

OK, maybe it's fixed.

> Tried to run the version 25.0.1 from the link you provided and it only ran to check plugins and then it closed.

Maybe an extension or plugin caused it?  Does it work in safe mode or with a new profile? (-safe-mode, -P)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.