Closed Bug 948482 Opened 8 years ago Closed 8 years ago

We need a SSH client

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 878972

People

(Reporter: theotix, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Sorry for reporting this thing here, because this is more like feature request.


Actual results:

Sorry for reporting this thing here, because this is more like feature request.


Expected results:

Why ?
In a centralized world, having a personnal server is not only for the developpers, and stay connected with it's server is important, especially as phones are increasingly being used as smart-computers. All this to say that we need an SSH client for our FirefoxOS phones.
Wished features

    Bookmarks

    Maybe mosh-client implentation (It's for mobile device, remember)

Resources

    Obvious: http://en.wikipedia.org/wiki/Secure_Shell

    Client-side terminal emulation: http://en.wikipedia.org/wiki/Web-based_SSH#Client-side_terminal_emulation

    Mosh: http://mosh.mit.edu/

Documentation

    RFC 4250, The Secure Shell (SSH) Protocol Assigned Numbers

    RFC 4251, The Secure Shell (SSH) Protocol Architecture

    RFC 4252, The Secure Shell (SSH) Authentication Protocol

    RFC 4253, The Secure Shell (SSH) Transport Layer Protocol

    RFC 4254, The Secure Shell (SSH) Connection Protocol

Handicaps

    SSH uses cryptology protocols that may have not been implemented in JS before.

Needs / required

    Diffie-Hellman

    RSA Key Exchange

Suggestions

    it could be good to look at the side of FireSSH, a Firefox addon for Firefox (desktop), maybe fork it ?
Looks like idea for 3-rd party application rather than feature of OS.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 878972
You need to log in before you can comment on or make changes to this bug.