[B2G][Email] Edit Option is enabled with no results in Search Mode.

RESOLVED DUPLICATE of bug 1007313

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 1007313
4 years ago
4 years ago

People

(Reporter: PBylenga, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: dogfood1.2, ux-most-wanted, user-research)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8345395 [details]
EmailSearchEditOption_log.txt

Description:
In Search Mode, without searching mail first, Edit Option is enabled and can be activated bringing the user to an edit mode with no content.  This issue reproduces across all tabs available in Search Mode. This was tested with a Gmail account and a Fastmail account.  This issue does not reproduce when user searches for a term that has 0 matches, in this case the Edit Option is grayed out and does not respond to tap.

Prerequisites:
Have an email account setup and associated with Email App.

Repro Steps:
1) Updated Buri to Build ID: 20131209004003
2) Launch Email App
3) Tap Search Mode
4) Observe Edit option at the bottom of the screen and attempt to activate it

Actual:
Button is not grayed out and can be interacted with.

Expected:
Button is grayed out and does not respond to tap until at least one email is found by search.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131209004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/f684b8f159a3
Gaia: f615ae7acb6731d191b3094e10e314bc28359bbb
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: v1.2_20131115

Notes:
Repro frequency: 5/5, 100%
See attached: logcat


Issue does reproduce on 1.1

Environmental Variables
Device: Buri v1.1 COM RIL
Build ID: 20131210041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/05117f42088f
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281 
Firmware Version: 20131115

Updated

4 years ago
Duplicate of this bug: 951861

Updated

4 years ago
Duplicate of this bug: 980665

Comment 3

4 years ago
Adding note to also remember to change edit mode to only be accessible from non-empty lists, generally.
Blocks: 994991
Whiteboard: dogfood1.2 → dogfood1.2, ux-most-wanted, user-research
I don't think this is specific to search mode; duping to the bug with the identified fix.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007313
You need to log in before you can comment on or make changes to this bug.