No h264 playback on xperia tablet z

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Heiko.Klein, Unassigned)

Tracking

26 Branch
Other
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Android; Tablet; rv:26.0) Gecko/26.0 Firefox/26.0 (Nightly/Aurora)
Build ID: 20131205073515

Steps to reproduce:

Steps to reproduce: I try to open a mp4/h264 video with my sony xperia go / JellyBean 4.1 android mobile. a) http://www.quirksmode.org/html5/tests/video.html b) http://youtube.com/html5


Actual results:

Actual results: a) The MP4/h264 video is not selectable, showing a message that mp4/h264 is not available: 'No video with supported format and MIME type found.' The webm or ogg/theora videos play well. b) 'What does my browser support', says 'no h264'


Expected results:

Tested with both chrome/android and firefox/linux+gstreamer: a) all videos are playable b) 'What does my browser support', say 'h264 enabled'


I've seen this behaviour before on Xperia go : bug 919660 , but FF26 fixed the issue there, while it remains on the tablet z.

Updated

5 years ago
Component: General → Video/Audio
Product: Firefox for Android → Core
Version: Firefox 26 → 26 Branch
When you attempt to press play or load a video, can you attach a log-cat from your device?

This is possibly a dupe of already known issues.
(Reporter)

Comment 2

5 years ago
I don't know how to retrieve a 'log-cat from my device', so when this really is needed, I'll need to learn about debugging on android.

But even then: I cannot play a h264 video, because all videos with only type="video/mp4" say 'no video with supported format and MIME type found'. There is no button to press.
(Reporter)

Comment 3

5 years ago
I Just upgraded the tablet to 4.3 (official upgrade from sony as of 23.12.2013), and now h264 playback works without any problems. So I will close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.