Anchor tag in OS X doesn't receive focus when pressing TAB

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Carlos Aguayo, Unassigned)

Tracking

25 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8345510 [details]
focus.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

Have a visible anchor tag with an href in the DOM. Tab in order to try to reach the element.

* See either the attachment or http://jsfiddle.net/carlosaguayo/9h9Te/.
* Click on the first text input in order to make it be focused.
* Press TAB.
* The expected behavior is that now the focus is on the anchor tag instead of the second text input.

I tried this in FF 25, 26 and nightly (29).


Actual results:

In OS X, the anchor never receives the focus. Using Firefox but under Windows, the anchor gets the focus as expected.
I also tried Chrome in OS X and the element does get the focus (in order to prove that it's not a operating system issue).


Expected results:

The element should receive the focus.

Comment 1

4 years ago
This works for me. You probably have the preference for focusable elements in OS X's system preferences (search for "Keyboard shortcuts") set to "Text boxes and lists only" instead of "All controls".
(Reporter)

Comment 2

4 years ago
Thanks for your quick response. Indeed updating the setting to "All controls" gave me the expected behavior. It's still strange that Chrome had the right behavior despite the setting but this works for me. Thanks!

I'm closing the issue as invalid then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.