Closed Bug 948714 Opened 7 years ago Closed 7 years ago

[B2G][First Time Experience][Date & Time] Continent and city selections do not update text or imagery until user changes date or time

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox29 affected, b2g-v1.2 unaffected, b2g-v1.3 affected)

RESOLVED WORKSFORME
Tracking Status
firefox29 --- affected
b2g-v1.2 --- unaffected
b2g-v1.3 --- affected

People

(Reporter: bzumwalt, Unassigned)

References

()

Details

(Keywords: regression)

Description:
When user changes continent and/or city on Date & Time screen during FTE/FTU, the page does not update with new location information imagery or text until user selects date or time.

Repro Steps:
1) Updated Buri to Build ID: 20131210040206
2) Open Settings app
3) Navigate to Device Information>More Information>Reset Phone
4) On FTE, select next until Date & Time screen is reached
5) Press "Change" button next to current city
6) Select new city
7) Press "OK"


Actual:
Continent and city info does not update until date or time is changed.

Expected:
Continent and city info changes when city or continent is changed.

Environmental Variables
Device: Buri v 1.4 Mozilla RIL
Build ID: 20131210040206
Gecko: http://hg.mozilla.org/mozilla-central/rev/df82be9d89a5
Gaia: c952e2756c03eceb4de6a3eba15651741a62f9e8
Platform Version: 29.0a1
Firmware Version: V1.2_US_20131115


Notes:
Repro frequency: 3/3, 100%
See attached: video clip - http://www.youtube.com/watch?v=PiWyl44_2hM
Issue does NOT repro on Buri in 1.3

Result: Continent and city info changes when city or continent is changed.

Environmental Variables
Device: Buri v 1.3 Mozilla RIL
Build ID: 20131210004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/e0c328d99742
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Platform Version: 28.0a2
Firmware Version: V1.2_US_20131115


Issue does NOT repro on Buri in 1.2

Result: Continent and city info changes when city or continent is changed.

Environmental Variables
Device: Buri v 1.2 COM RIL
Build ID: 20131210004008
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/e535d93d88ad
Gaia: 3bede56043379283cb0f6673730f91be88018d13
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115
Issue now occurs on today's 1.3 build on Buri. This issue did NOT appear on yesterday's 1.3 build.

Result: Continent and city info does not update until date or time is changed.

Environmental Variables
Device: Buri v 1.3 Mozilla RIL
Build ID: 20131211004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6bb84d0bc170
Gaia: 7a2ccae2a546ac4d981d250272dafa630c926422
Platform Version: 28.0a2
Firmware Version: V1.2_US_20131115
Since it's FTU, marking it as a blocker.
blocking-b2g: --- → 1.3?
QA Contact: sparsons
While I was able to repro this issue on the Buri 1.3 Build ID: 20131211004003 and the Buri Master Build ID: 20131210040206, I am no longer able to repro this issue on the latest 1.3 Aurora and Master builds. 


No longer repros on Buri Master Build ID: 20131216040201

Gaia   358cd74fd2b2ef5d541f71a5d53d65d6a7335424
SourceStamp f67feb33a974
BuildID 20131216040201
Version 29.0a1


Also, no longer repros on Buri Aurora 1.3 Build ID: 20131216004002

Gaia   1752e9e8f2b84b9db5d96ae5940596957fc8ed6c
SourceStamp 2ec5a40f544e
BuildID 20131216004002
Version 28.0a2
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.