Closed Bug 948725 Opened 6 years ago Closed 6 years ago

Intermittent cppunittests TEST-UNEXPECTED-FAIL | Response written

Categories

(Core :: Networking, defect)

All
Windows 8
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox27 --- unaffected
firefox28 --- fixed
firefox29 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: KWierso, Assigned: schien)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

13:32:09     INFO -  - Aggregate Batch Transaction Stress Test:
13:32:09     INFO -  -----------------------------------------------------
13:32:14     INFO -  Stress test of 500 iterations (may take a while) ... 100 200 300 400 500 passed
13:32:14     INFO -  TEST-PASS | 2630250 transactions processed during stress test
13:32:14     INFO -  Finished running nsITransactionManager tests.
13:32:14     INFO -  cppunittests INFO | Running test TestTypedEnum.exe
13:32:14     INFO -  ProcessManager UNABLE to use job objects to manage child processes
13:32:14     INFO -  ProcessManager NOT managing child processes
13:32:14     INFO -  cppunittests INFO | Running test TestTypeTraits.exe
13:32:14     INFO -  ProcessManager UNABLE to use job objects to manage child processes
13:32:14     INFO -  ProcessManager NOT managing child processes
13:32:14     INFO -  cppunittests INFO | Running test TestUDPSocket.exe
13:32:14     INFO -  ProcessManager UNABLE to use job objects to manage child processes
13:32:14     INFO -  ProcessManager NOT managing child processes
13:32:14     INFO -  Running UDP ServerSocket tests...
13:32:14     INFO -  ProcessPriorityManager - InitProcessPriorityManager bailing due to prefs.
13:32:14     INFO -  TEST-PASS | Request written by Send
13:32:14     INFO -  TEST-PASS | Packet received on server from 127.0.0.1:56683
13:32:14     INFO -  TEST-PASS | Request 0x68656c6f received as expected
13:32:14     INFO -  *** Attempting to write response 0x6f6c6568 to client by OutputStream...
13:32:14     INFO -  TEST-PASS | Response written
13:32:14     INFO -  TEST-PASS | Packet received on client from 127.0.0.1:56682
13:32:14     INFO -  TEST-PASS | Request 0x6f6c6568 received as expected
13:32:14     INFO -  TEST-PASS | Request written by SendWithAddress
13:32:14     INFO -  TEST-PASS | Packet received on client from 127.0.0.1:56682
13:32:14     INFO -  TEST-PASS | Request 0x68656c6f received as expected
13:32:14     INFO -  *** Attempting to write response 0x6f6c6568 to server by SendWithAddr...
13:32:14     INFO -  TEST-PASS | Response written
13:32:14     INFO -  *** Attempting to close server ...
13:32:14     INFO -  TEST-PASS | Server closed
13:32:14     INFO -  TEST-PASS | Packet received on client from 127.0.0.1:56682
13:32:14     INFO -  TEST-PASS | Request 0x68656c6f received as expected
13:32:14     INFO -  *** Attempting to write response 0x6f6c6568 to server by SendWithAddr...
13:32:14  WARNING -  TEST-UNEXPECTED-FAIL | Response written
13:32:14     INFO -  Finished running UDP ServerSocket tests.
13:32:14     INFO -  cppunittests INFO | Running test TestWeakPtr.exe
13:32:14     INFO -  ProcessManager UNABLE to use job objects to manage child processes
13:32:14     INFO -  ProcessManager NOT managing child processes
13:32:14     INFO -  cppunittests INFO | Running test TestWebGLElementArrayCache.exe
13:32:14     INFO -  ProcessManager UNABLE to use job objects to manage child processes
13:32:14     INFO -  ProcessManager NOT managing child processes
13:32:16     INFO -  C:\slave\test\build\tests\cppunittests\TestWebGLElementArrayCache.exe: all 6758110 tests passed
Jason or Patrick, can you please help find an owner for this?
Summary: Intermittent cpuunittests TEST-UNEXPECTED-FAIL | Response written → Intermittent cppunittests TEST-UNEXPECTED-FAIL | Response written
Shih-Chiang, you wrote TestUDPSocket.cpp, right?  Do you have any idea why we're getting this failure?
Flags: needinfo?(schien)
From the log, The server socket is closed before client socket received the packet. Therefore, test case is failed because client socket receives some random data. We might need to use lock instead of |PumpEvent| for waiting asynchronous event[1].

[1] http://dxr.mozilla.org/mozilla-central/source/netwerk/test/TestUDPSocket.cpp?from=TestUDPSocket.cpp#254
Flags: needinfo?(schien)
Shih-Chiang, do you think you can fix this?  I don't know who else to give it to.  Obviously not the highest priority, but it's failing often enough that it would be nice to fix.
Flags: needinfo?(schien)
Sure, I'll put this bug into my queue explicitly.
Assignee: nobody → schien
Flags: needinfo?(schien)
I shouldn't invoke |QuitPumpingEvents| after sending packet in UDPClientListener [1]. This might cause the server socket being closed before the last packet is received by server socket.

[1] http://dxr.mozilla.org/mozilla-central/source/netwerk/test/TestUDPSocket.cpp?from=TestUDPSocket.cpp#122
Duplicate of this bug: 950192
I'll flag review? after try shows stable green with this patch.
https://tbpl.mozilla.org/?tree=Try&rev=f435d4983c79
Comment on attachment 8367090 [details] [diff] [review]
fix-event-pumping.patch

Looks good on try result, flag for review.
Attachment #8367090 - Flags: review?(jduell.mcbugs)
Comment on attachment 8367090 [details] [diff] [review]
fix-event-pumping.patch

Review of attachment 8367090 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.  Thanks for tracking this down!
Attachment #8367090 - Flags: review?(jduell.mcbugs) → review+
https://hg.mozilla.org/mozilla-central/rev/c113e2615e8f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.