[fugu][buri][contact] tap on 'enter' on keyboard will clear all input in custom label

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: angelc04, Assigned: gtorodelvalle)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

Attachments

(1 attachment)

This is still reproducible on v1.2 and v1.3.

STR:
1. Launch Contact
2. Tap on '+' to Open 'Add Contact' page
3. Tap on "Mobile" or "Personal"... to open 'Label" page
4. Swipe to the bottom
5. Input some custom label, and press 'Enter" button on the keyboard
   -> The input is cleared.
[Expect] Pressing enter should close Keyboard, but not clear the input.

Test build:
V1.2
Gaia      f615ae7acb6731d191b3094e10e314bc28359bbb                         
Gecko                                                                      
http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/f684b8f159a3         
BuildID   20131209004003                                                   
Version   26.0                                                             
ro.build.version.incremental=eng.archermind.20131114.105818 

V1.3
Gaia      1d45d1dc3201059d5c8f2efdeb92c04576d8e161                         
Gecko     http://hg.mozilla.org/mozilla-central/rev/9f12a9fab080           
BuildID   20131209053402                                                   
Version   28.0a1                                                           
ro.build.version.incremental=eng.archermind.20131114.105818
blocking-b2g: --- → 1.3?
Flags: needinfo?(styang)

Comment 1

5 years ago
German,

Can we reproduce this on v1.3 Buri / Unagi? If not I don't think it should be blocking for 1.3
Flags: needinfo?(gtorodelvalle)
In fact, it does happen even in master with a minor remark: if there is a word suggestion it is selected when clicking the "Enter" button. If no word suggestion, the content of the field is deleted as mention in the description of the bug.

It reproduces in 1.2, 1.3 and master.
Flags: needinfo?(gtorodelvalle)
Assignee: nobody → gtorodelvalle
Created attachment 8348913 [details]
14777.html

Sincerely I do not like to solve bugs when I do not totally understand what is going on and this is one of these :( For some reason, when clicking on the return key when the focus is on the custom field, the click event of the "Mobile" tag is fired :-O (see https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/js/contacts_tag.js#L35) and this provokes the "Mobile" tag to be selected and the custom tag content to be deleted in case there was content on it (as a consequence of https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/js/contacts_tag.js#L63)

The solution is to prevent the default behaviour when typing the return key when the focus is on the custom tag input field.

BTW, clicking on the return key when the focus is on the custom tag input field will basically do nothing. It will not close the keyboard as suggested by pcheng since this is out of the scope of the Contacts app. In fact, it is the same behaviour as clicking on the search bar in the Contacts app to enter the search mode and clicking on the return key in the keyboard, it basically does nothing.
Attachment #8348913 - Flags: review?(jmcf)

Updated

5 years ago
Flags: needinfo?(styang)

Comment 4

5 years ago
Comment on attachment 8348913 [details]
14777.html

thanks for the patch, Germán
Attachment #8348913 - Flags: review?(jmcf) → review+
triage: 1.3+
blocking-b2g: 1.3? → 1.3+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g-v1.3: --- → affected
Uplifted 0e8a73a74ba28715d55c6c657e3befa25cf6c915 to:
v1.3: 9ae1e1b4909c3fd9f667361c1b35e99a63737a33
status-b2g-v1.3: affected → fixed
You need to log in before you can comment on or make changes to this bug.