If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox download page says I run the most recent version while I have an old one

RESOLVED INVALID

Status

www.mozilla.org
General
--
major
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Go to firefox.com with Firefox 25.0.1 (Linux)
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0

Expected result:
- Land on http://www.mozilla.org/fr/firefox/new/ and get proposed Firefox 26 for download

Actual result:
- http://www.mozilla.org/fr/firefox/new/ says that I already have the latest version of Firefox

If I go to the site with Chromium, I do get the download box on the page with Firefox 26, I think there is a bug with the version detection in the download process.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935673

Comment 2

4 years ago
This is on purpose for people who have not restarted their browser from a silent update yet and are running latest version minus 1. I vote that we keep this as-is until we have a way to detect if a silent update is applied and just waiting for an update. This has been discussed many times in the past few months and SUMO is doing latest version minus 1 too.
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.