Closed Bug 948862 Opened 6 years ago Closed 6 years ago

[Contacts] The first time exporting a contact to SIM creates a duplicate of the contact in the contact list

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed, b2g-v1.3 fixed)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: isabelrios, Assigned: jmcf)

Details

(Keywords: regression)

Attachments

(2 files)

Seen with v1.2 12/11 build:
Gecko-bc20708
Gaia-096722a

STR
Create a contact in an empty contact list
1. Tap on Contacts settings
2. Tap on Export contacts-> SIM
3. Select the contact previously created and tap on Export
4. Tap on Done and go back to the contact list

EXPECTED
The contact has been expoted correctly to SIM and it remains in the contact list as it was before exporting it

ACTUAL
The contact is exported successfully but a duplicate is created in the contact list.

This is likely a regression due to bug 944575. It is a koi+ so nominating this as koi? too because the export funcionallity is failing.
Assignee: nobody → jmcf
Attached file 14567.html
patch for master
Attachment #8345817 - Flags: review?(francisco.jordano)
Attached file 14568.html
patch for v1.2
Attachment #8345818 - Flags: review?(francisco.jordano)
Comment on attachment 8345817 [details]
14567.html

Looking good to me.

Thanks JMC!
Attachment #8345817 - Flags: review?(francisco.jordano) → review+
Comment on attachment 8345818 [details]
14568.html

Looking good to me too.

Should we add some flags to uplift to v1.2, also, don't know if it's even possible taking into account we are in 1.3.
Attachment #8345818 - Flags: review?(francisco.jordano) → review+
blocking-b2g: koi? → koi+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This needs to be ported to the v1.3 branch as well.
Checked with today's (12/16) v1.2 build, it is solved.
Gecko-f6f325b
Gaia-fcf1c2f

Will verify it when checked also in master.

Thanks
Uplifted 3b59454125a4535ca26cc5f478a9073393d374f9 to:
v1.3: a2b0e97baf6ee91f9afeadeb604550b05c0ec65f
Verified after checking it also in v1.3. Not possible to reproduce the bug with 01/08 build:
Gecko-e499b1f
Gaia-d578331
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.